Foxpro 2.6 ODBC Drivers Inconsistancies with VFP6 Driver.

Foxpro 2.6 ODBC Drivers Inconsistancies with VFP6 Driver.

Post by Chris Parson » Tue, 22 Aug 2000 12:42:40



Microsoft seems keen for everyone to use the VFP ODBC drivers for
foxpro, as upgrading ODBC with any later version forces you to use the
VFP Drivers instead of the Foxpro ODBC. The problem is that there is
incompatabilities between the two that mean the recoding of all our
developments. Such inconsitancies include True and False values (allowed
in foxpro 2.6 drivers) are not recognised in VFP6 which requires .t. and
.f. (inconsistant with most other drivers) Also instering into memo
fields must be less that 255 characters with the VFP drivers. Microsoft
offered no solution just asked $260 to look at it for me. Any
suggestions? Is there anyway we can run with the old driver? as
deinstalling the latest version of odbc is easy, as there is no
deinstall.

Thankyou for any help

 
 
 

Foxpro 2.6 ODBC Drivers Inconsistancies with VFP6 Driver.

Post by Joe Zelinsk » Tue, 22 Aug 2000 04:00:00


Chris,
I too have been frustrated by this, as I need to read data in a legacy
system which would involve way too much re-writing to adopt the VFP driver.
I have managed to do EXACTLY what you mentioned-- go back to the older
FoxPro drvier.
There are about 5 .DLL files that need to be in the \WINDOWS\SYSTEM (or
\WINNT\SYSTEM32, etc.) folder to make it work.  I just renamed the newer
files to a ".new" extension, so I could get back to where I was if it didn't
work.
The only thing is, I have not been able to make this work on Windows2000.
Let me know if you want some specifics on what files you need.

Joe Z.
Oregon, USA


> Microsoft seems keen for everyone to use the VFP ODBC drivers for
> foxpro, as upgrading ODBC with any later version forces you to use the
> VFP Drivers instead of the Foxpro ODBC. The problem is that there is
> incompatabilities between the two that mean the recoding of all our
> developments. Such inconsitancies include True and False values (allowed
> in foxpro 2.6 drivers) are not recognised in VFP6 which requires .t. and
> .f. (inconsistant with most other drivers) Also instering into memo
> fields must be less that 255 characters with the VFP drivers. Microsoft
> offered no solution just asked $260 to look at it for me. Any
> suggestions? Is there anyway we can run with the old driver? as
> deinstalling the latest version of odbc is easy, as there is no
> deinstall.

> Thankyou for any help