Foxpro 2.6 dos to Visual Foxpro 6

Foxpro 2.6 dos to Visual Foxpro 6

Post by Brainard Mille » Thu, 25 Jul 2002 06:40:25



I have converted my dos program to visual foxpro6.


The spooler seems to jam as soon as output is sent to it.

should set printer to / set device to printer  work in visual foxpro6?

How can i solve this problem?

--
Posted via Mailgate.ORG Server - http://www.Mailgate.ORG

 
 
 

Foxpro 2.6 dos to Visual Foxpro 6

Post by Dennis P. Harr » Thu, 25 Jul 2002 07:54:43


On Tue, 23 Jul 2002 21:40:25 +0000 (UTC) in
comp.databases.xbase.fox, "Brainard Miller"


> I have converted my dos program to visual foxpro6.


> The spooler seems to jam as soon as output is sent to it.

> should set printer to / set device to printer  work in visual foxpro6?

> How can i solve this problem?

use the report designer and foxpro reports.

 
 
 

Foxpro 2.6 dos to Visual Foxpro 6

Post by Neil Waterwort » Fri, 26 Jul 2002 00:54:33


> I have converted my dos program to visual foxpro6.


> The spooler seems to jam as soon as output is sent to it.

> should set printer to / set device to printer  work in visual foxpro6?

> How can i solve this problem?


says. The printer (HPLJ 9000) is selected using set printer to name
<printername>. I might also use set printer on ... don't have the code
available right now. It works fine - frequently handles over 4000 forms in a
single run. The job is spooled to a Netware queue and then on to a print
server.

What printer setup do you have? e.g. laser or dot matrix, networked or
standalone, etc.

I appreciate that some complex forms don't easily lend themselves to the
report generator, but if you can convert it that way, it's your best course
of action.

 
 
 

Foxpro 2.6 dos to Visual Foxpro 6

Post by Brainard Mille » Fri, 26 Jul 2002 06:05:52


I am using an HpDJ960 & a Oki ml320(dot).

The spooler jams or prints trash.
If i run the same code in a dos window, It works ok.
I would love to see how you got it to print.
I tried sending to a file,  and TYPE > prn, but this will not eject a
page.

--
Posted via Mailgate.ORG Server - http://www.Mailgate.ORG

 
 
 

Foxpro 2.6 dos to Visual Foxpro 6

Post by Neil Waterwort » Fri, 26 Jul 2002 09:06:09


> I am using an HpDJ960 & a Oki ml320(dot).

> The spooler jams or prints trash.
> If i run the same code in a dos window, It works ok.
> I would love to see how you got it to print.

I'll send more ideas tomorrow when I can access the code from work. There is
no DOS element to the setup.

A few questions. What are the Windows printer names, how are you selecting
them, are you using the correct and latest Windows drivers for them, and are
you sending through any escape sequences, PCL codes, etc.? Are you trying to
print anything "unusual", like barcodes or non-standard fonts? What are your
spooler settings?

Quote:> I tried sending to a file,  and TYPE > prn, but this will not eject a
> page.

Issuing the "set printer to", or the "eject" command might work here.

More later ...

 
 
 

1. WTB: Foxbase+, FoxPro 1.0 for Win, FoxPro 2.0 for DOS, FoxPro 2.6 DOS/Win

If you have disks, manuals, or complete copies of Foxbase+, FoxPro 1.0
for Win, FoxPro 2.0 for DOS, or FoxPro 2.6 for DOS or Win you would be
willing to sell at some price, please send condition and price to

--
Eric Engelmann, Owner/Technical Director
EMS Professional Software/Consulting
4505 Buckhurst Ct.
Olney MD 20832-1830
Voice:+1(301)924-3594     Fax:+1(301)963-2708

http://www.wdn.com/ems

2. Access ODBC drivers

3. Foxpro 2.5 Dos and Foxpro 2.6 Windows

4. Data Acces and SQL Server 2000/COM+

5. How to Save data in Foxpro 2.6 using Visual Foxpro Driver (ADO)

6. SLOW response

7. Migrating Graphs from FoxPro 2.6 to Visual FoxPro.

8. bcp in givin 'incorrect syntax near the keyword order'

9. ForSale/Trade: FoxPro 2.6 for Windows and Visual FoxPro 3.0

10. Fox 2.6 DOS and Visual Foxpro

11. Converting foxpro 2.6 to visual foxpro

12. FoxPro 2.6 for DOS - Cursor colour is wrong in a DOS Window

13. foxpro 2.6 dos to 2.6 unix