Ingstop problem on Alpha machine

Ingstop problem on Alpha machine

Post by A.M. de Jon » Sun, 14 Mar 1999 04:00:00



Hi,

We have A problem with ingstop on an Open Ingres 1.2 installation.
Ingstop stops or seems to hung so Ingres doesnot stop.
It is not always the case but it happens every now and then.
We have an Unix environment on a Dec Alpha machine.
Has anybody have the same experience ??

Greetings,

Arno de Jong, The Netherlands.

 
 
 

Ingstop problem on Alpha machine

Post by Martin Bow » Mon, 15 Mar 1999 04:00:00


Hi Arno,

    I've been running OI1.2 on DEC Alphas with DUNIX for some time now and I
    havent experienced this problem. Or at least cant recall having had this
    one.

    What version of DUNIX are you runing with and what OI patch are you using?
    Do you knnow at what point in the shutdown you have stopped? Do you get a
    prompt back or does the command simply hang? Exactly how do you invoke
    ingstop (ie do you use a -force or -immediate option or do you use the
    timeout option?

    Remember the ingstop command is a shell script and hence you can edit it
    to put in some tracing. A few echos a 'set -x' here or there and who knows
    what you may find!

    If I had to guess then I'd back a problem cleaning shared memory and
    semaphores. There have been problems in this area caused by OS level
    differences between 3.2 and 4.0 DUNIX. Without the right patch these can
    manifest themselves in interesting ways. One that might be interesting to
    consider is checking the key of the shared memory segments used by ingres.
    If the key begins 0x3 then you may be in for difficulty.

    Martin Bowes.

Quote:

> Hi,

> We have A problem with ingstop on an Open Ingres 1.2 installation.
> Ingstop stops or seems to hung so Ingres doesnot stop.
> It is not always the case but it happens every now and then.
> We have an Unix environment on a Dec Alpha machine.
> Has anybody have the same experience ??

> Greetings,

> Arno de Jong, The Netherlands.

--
Random Duckman Quote #14:
Bernice - You were suppose to get your dog neutered, I caught him
          looking looking funny at the hamster again!

 
 
 

Ingstop problem on Alpha machine

Post by Ingvar Larsso » Tue, 16 Mar 1999 04:00:00


Can you see something in the errorlog? I don't know how OI 1.2
behave but in 6.4 ingstop could hang if you have had some
"Ingres out of locks" errors.

Well, not much help but maybe a hint.

/Ingvar


Quote:>Hi,

>We have A problem with ingstop on an Open Ingres 1.2 installation.
>Ingstop stops or seems to hung so Ingres doesnot stop.
>It is not always the case but it happens every now and then.
>We have an Unix environment on a Dec Alpha machine.
>Has anybody have the same experience ??

>Greetings,

>Arno de Jong, The Netherlands.

 
 
 

Ingstop problem on Alpha machine

Post by Wim de Boe » Wed, 17 Mar 1999 04:00:00


Hi Arno,

There has been a problem with OI 1.2/01. One of the shutdown
processes would execute so fast, that it runs ahead of another one,
for which it should wait. This is solved in (at least) patch 5070,
maybe even 4789. I must add that this was for Dec Alpha running
OpenVMS.

HTH

--
Met vriendelijke groet/Kind regards,

Wim de Boer

ORAP
Treubstraat 1h
2280 CD  RIJSWIJK ZH
tel. : 070-413 0999
fax. : 070-414 0544

 
 
 

1. To ingstop -f or ingstop -kill ?

Thought I'd use a lifeline and ask the audience...............

I know ingstop -kill works when most other things fail.
But the sysref.pdf (and ingstart -help) only mentions
a -f (force or immediate ) parameter.

What exactly is the difference ?

Andre

2. Return Type of Array

3. Trouble with SQL6.5 NT4 on alpha machine

4. Boldstyle in vb3/vb4 16-bit?

5. Alpha machines' tps

6. Data Missing in DEJANEWS

7. Problem changing from a One procesor machine to dual machine (sun solaris)

8. sorting a repeating field: possible?

9. Ingstop -force twice

10. Using ingstop -force once a week

11. Ingstart and Ingstop return codes

12. unable to ingstop

13. Ingres II ingstop