"Data source is not found" error with data source is there

"Data source is not found" error with data source is there

Post by mahj » Sat, 02 Sep 2000 12:21:25



Holleo Every one:
   I develop a Dialog-Based program to use odbc,  and it work well.
But when  I copy the same code to my in-process component server project
or my nt-service project, it does work at all. And the error message is:
 "Data source not found and no default driver defined". But the data
source is there, and I can connect to it and work well in my Dialog-Based
program.
   I don't konw why, and thank you in advance for you highly appreciated
advice

 
 
 

"Data source is not found" error with data source is there

Post by Gerd Streube » Sat, 02 Sep 2000 15:20:00


I would tell you my experience with this error message.

- If your DSN is a user DSN and you try to access this DSN from a different
user, the system couldn't find the desired DSN.
- If the DSN exists but the database name, e.g. the name of the excel file
or DBase file, has changed or was removed you will get the message.
- If your actual DSN is a system DSN and you create accidentally a user DSN
with the same name, you get connected only to the user DSN which has a
totally different database name.

Concerning ODBC and COM I have no experience.


>Holleo Every one:
>   I develop a Dialog-Based program to use odbc,  and it work well.
>But when  I copy the same code to my in-process component server project
>or my nt-service project, it does work at all. And the error message is:
> "Data source not found and no default driver defined". But the data
>source is there, and I can connect to it and work well in my Dialog-Based
>program.
>   I don't konw why, and thank you in advance for you highly appreciated
>advice



 
 
 

1. help - "data source name not found"

I have created a web application that uses ASP on the front end, which calls
VB functions that read and write to an Access database.

Everything works great when the VB DLL is in run mode, but after it is
compiled, I am getting the following message in the Event Viewer when trying
to connect to the Access database via ODBC:

"Data source name not found and no default driver specified from Microsoft
OLE DB Provider for ODBC drivers."

I have already created the ODBC data source (under System DSN).

Here is the relevant code from the DLL:

Dim Conn As ADODB.Connection

Set Conn = New ADODB.Connection
Conn.Open "webdb"  //////////this is where it is blowing up

Any suggestions?

Thanks.

2. OpenLink ODBC Info

3. "Data source not found" message

4. Universal Server: DataBlade API or CLI

5. "Error Configuring Data Source"

6. Info on Database Implementations wanted

7. "not data found" error in replication

8. Job Decides to Fail and Leaves Clue

9. Oracle Data Source - potential "security hole"

10. "Invalid data source" with DataReport

11. "Data source name too long" exception

12. Data source name not found error

13. ODBC Connection error - Data Source Name not found and no default server specified