ado 2.0/2.1 on Windows 2000/XP

ado 2.0/2.1 on Windows 2000/XP

Post by Rafi » Thu, 13 Mar 2003 19:23:27



I am trying to install an application (that was designed
to run on Win98) on Windows 2000 (or XP). The application
installs (as part of the installation) ADO 2.0 and ADO
2.1 - on Win2k and XP I get a notice that it is not for
this OS and I should upgrade via the service Packs. It
then installs DCOM (for Win98) and also fails due to
incorrect OS. (BTW, it asks for a confirmation before
installing each option).

I know there is a way to get it to work, as I did it
successfully once before and we have a Win2k box running
this app. However, it was a while ago and I do not
remember how I got it going..

How can I get such an app working in windows 2000/XP?

Thanks
Rafi

 
 
 

ado 2.0/2.1 on Windows 2000/XP

Post by Luca » Thu, 20 Mar 2003 16:49:33


Win 2000 includes alaready ADO 2.5 so you do not need to distribut ado. I
recommend you make a separate setup for Win2000/XP wich does not install any
ado components.

Luca


Quote:> I am trying to install an application (that was designed
> to run on Win98) on Windows 2000 (or XP). The application
> installs (as part of the installation) ADO 2.0 and ADO
> 2.1 - on Win2k and XP I get a notice that it is not for
> this OS and I should upgrade via the service Packs. It
> then installs DCOM (for Win98) and also fails due to
> incorrect OS. (BTW, it asks for a confirmation before
> installing each option).

> I know there is a way to get it to work, as I did it
> successfully once before and we have a Win2k box running
> this app. However, it was a while ago and I do not
> remember how I got it going..

> How can I get such an app working in windows 2000/XP?

> Thanks
> Rafi