Error : Query must be updatable

Error : Query must be updatable

Post by Andre Bezuidenhou » Fri, 18 Feb 2000 04:00:00



Hi there

I am using VFP6. I need to export from VFP tables to Paradox 5 tables. I
am using the ODBC Paradox Driver supplied.

This program works fine on any machine running in Win95, but when I run
it on Win98, I get the following error
  Connectivity error [Microsoft][ODBC Paradox Driver] operation must be
an updatable query

I am using the MS Paradox Driver V 4.00.3711.08

As I said this problem only occurs in Win98.

Does anyone have any suggestions as to what could be the problem ?

Regards
Andre Bezuidenhoud

 
 
 

1. Operation must use an updatable query 3073 - ODBC Error

I am using VB6 to and SQL Server 7.0    .. I can read from the DB fine but
when I try to do a delete statement it gives me the error :  Operation must
use and updatable query error # 3073  ...

the thing is that it works fine from the query analyzer .. when I cut and
paste the code to vb .. it dosen't ..

I also can't use the insert statement from VB either ... it gives me a 3158
error 'Insert on linked table ??? failed' .. but the table isn't a linked
table .. and also works fine from the query analyzer ...

any suggestions ??

2. Scheduling Utility

3. Operation must use an updatable query. (Error 3073)

4. Renaming SQL Instance

5. Run time error 3073 -Operation must use an updatable query

6. SqlhostsEditor for NT

7. timetravel

8. Error 3073 - Operation must use an updatable query

9. Error 3073 : Updatable Query required

10. ODBC error: Operation must use an updatable query