Warnings when compiling in i4gl or using c4gl.

Warnings when compiling in i4gl or using c4gl.

Post by Prasad S Shett » Fri, 24 May 2002 17:57:20



Hello Anybody,

We are facing a problem.

I have i4gl (version 7.31 UC5) on (OS & H/w Details: SCO Unix OpenServer release 5 with 4 CPU, 512 MB RAM, 8 GB RAID Datamini Server)

Firstly there was a problem of core dump whenever I would compile any module having more than 5 character name. One of the patches in the OS  (patch rs505a) was supposed to have caused this problem. The work around specified was using the environment variable C4GLFLAGS=-phase 12345. Now this resolved the problem.

I was then not able to link the libraries provided by Informix (the libraries provided in ${informixdir}/lib/tools like lib4gl.a). After studying the release notes for i4gl we realized that this version had dynamic linking of the libraries. But it was however not able to link the above file during compiling. The work around suggested in the release notes was using the -static command. So this has resolved the problem of linking the libraries. So now the C4GLFALGS='-phase 12345 -static'

Now the problem that I am facing is I get a warning when I compile my module viz.(warning: -h ignored when building a static executable)

So I am requesting anyone who would have encountered the same error/warning and how was it taken care of?

Prasad S Shetty

Get Your Private, Free E-mail from Indiatimes at http://email.indiatimes.com

 Buy Music, Video, CD-ROM, Audio-Books and Music Accessories from http://www.planetm.co.in
Get Your Private, Free E-mail from Indiatimes at http://email.indiatimes.com

 Buy Music, Video, CD-ROM, Audio-Books and Music Accessories from http://www.planetm.co.in