IDS 9.4 and Solaris 8

IDS 9.4 and Solaris 8

Post by blue » Fri, 30 May 2003 06:48:53



OK,

I read the machine notes on Informix IDS 9.4 and Solaris.  This is the first
time that I see a warning on this effect.

- The machine notes states that I need the Sun compiler to install onpladm,
ipload and blademgr.

- Before I never bother to look if I had a compiler and it seems that I do
not have.

Questions:
    1) Am I in lala land or did pre-IDS 9.4 did not need the Sun C compiler
?
    2) Can I install IDS 9.4 w/o the compiler (I am not going to use those
utility) ?

Thanks

 
 
 

IDS 9.4 and Solaris 8

Post by Thom » Fri, 30 May 2003 22:57:25



> OK,

> I read the machine notes on Informix IDS 9.4 and Solaris.  This is the first
> time that I see a warning on this effect.

> - The machine notes states that I need the Sun compiler to install onpladm,
> ipload and blademgr.

> - Before I never bother to look if I had a compiler and it seems that I do
> not have.

> Questions:
>     1) Am I in lala land or did pre-IDS 9.4 did not need the Sun C compiler
> ?
>     2) Can I install IDS 9.4 w/o the compiler (I am not going to use those
> utility) ?

> Thanks

My Solaris and IDS9.4 came in one box, and I don't have Solaris cc
too. My guess is you don't really need it. In case you do, you can
still try gcc. When I installed DBD::Informix, it run some test that
used esql of Informix to compile a ec program. I found esql is a shell
program and it uses cc as default compiler. I changed esql's code and
it worked like a charm.

 
 
 

IDS 9.4 and Solaris 8

Post by Helen Won » Sat, 31 May 2003 02:17:19


The machine notes is referring to the C++ Compiler Runtime and its patches
for the utilities you mentioned, not the actual C or C++ compiler.

1.  Pre-IDS 9.4, the C++ compiler runtime was required only for onpladm,
ipload, and blademgr.

2.  With IDS 9.4, we have additional C++ code in the engine and other
server utilities for enhanced Unicode support.   Therefore, IDS 9.4
requires C++  runtime  (even if you don't use onpladm, ipload, blademgr..).

Thanks,
Helen

                      "blue"                                                                                                

                      om>                      cc:                                                                          
                      Sent by:                 Subject:  IDS 9.4 and Solaris 8                                              
                      owner-informix-li                                                                                      

                      05/28/2003 02:48                                                                                      
                      PM                                                                                                    
                      Please respond to                                                                                      
                      "blue"                                                                                                

OK,

I read the machine notes on Informix IDS 9.4 and Solaris.  This is the
first
time that I see a warning on this effect.

- The machine notes states that I need the Sun compiler to install onpladm,
ipload and blademgr.

- Before I never bother to look if I had a compiler and it seems that I do
not have.

Questions:
    1) Am I in lala land or did pre-IDS 9.4 did not need the Sun C compiler
?
    2) Can I install IDS 9.4 w/o the compiler (I am not going to use those
utility) ?

Thanks