Help needed getting new IDS 9.3 installation working AIX 5.1 (assert failure)

Help needed getting new IDS 9.3 installation working AIX 5.1 (assert failure)

Post by Constant Angular Veloci » Fri, 20 Dec 2002 03:36:54



Looking for help getting a new installation of IDS 9.30FC2 on a new
installation of AIX 5.1 (power) working. (12-way p680, 8GB RAM).

Engine crashes upon attempted initialisation; details from af file as
follows:

Thread (1,main_thread,0,1)
File mtex.c Line: 415
Exception caught. Type:MT_EX_OS, Context: mem
Stack for thread: 1 main_thread
base:0x0000000000000000
len:0
...
some values here not noted
...

0x00000000000000000 ***unknown***

We experienced this problem trying to start a 'real' instance of
Informix, so subsequently attempted to start the demo database in
order to narrow down the variables (we have made no changes to the
onconfig for the demo database). $INFORMIXSERVER, $ONCONFIG,
$INFORMIXDIR and $INFORMIXSQLHOSTS have been set correctly.

The above problem occurs trying to start the demo database.

Many thanks,

Ben

 
 
 

Help needed getting new IDS 9.3 installation working AIX 5.1 (assert failure)

Post by David William » Fri, 20 Dec 2002 08:17:06




Quote:> Looking for help getting a new installation of IDS 9.30FC2 on a new
> installation of AIX 5.1 (power) working. (12-way p680, 8GB RAM).

> Engine crashes upon attempted initialisation; details from af file as
> follows:

  oninit -v

  gives what?

Quote:> Thread (1,main_thread,0,1)
> File mtex.c Line: 415
> Exception caught. Type:MT_EX_OS, Context: mem
> Stack for thread: 1 main_thread
> base:0x0000000000000000
> len:0

   ...
> some values here not noted
> ...

> 0x00000000000000000 ***unknown***

> We experienced this problem trying to start a 'real' instance of
> Informix, so subsequently attempted to start the demo database in
> order to narrow down the variables (we have made no changes to the
> onconfig for the demo database). $INFORMIXSERVER, $ONCONFIG,
> $INFORMIXDIR and $INFORMIXSQLHOSTS have been set correctly.

> The above problem occurs trying to start the demo database.

> Many thanks,

> Ben


 
 
 

Help needed getting new IDS 9.3 installation working AIX 5.1 (assert failure)

Post by Constant Angular Veloci » Fri, 20 Dec 2002 18:02:09





> > Looking for help getting a new installation of IDS 9.30FC2 on a new
> > installation of AIX 5.1 (power) working. (12-way p680, 8GB RAM).

> > Engine crashes upon attempted initialisation; details from af file as
> > follows:

>   oninit -v

>   gives what?

Checking group membership to determine server run modesucceeded
Reading configuration file
'/usr/informix/etc/onconfig.demo'...succeeded
Creating /INFORMIXTMP/.infxdirs ... succeeded
Creating infos file "/usr/informix/etc/.infos.demo_on" ...
"/usr/informix/etc/.conf.demo_on" ... succeeded
Writing to infos file ... succeeded
Checking config parameters...succeeded
Allocating and attaching to shared memory...succeeded
Creating resident pool 1696 kbytes...succeeded
Creating buffer pool 20000 kbytes...succeeded
Creating buffer pool 8 kbytes...succeeded
Initializing rhead structure...succeeded
Initializing ASF ...succeeded
Initializing Dictionary Cache and SPL Routine Cache...
 
 
 

Help needed getting new IDS 9.3 installation working AIX 5.1 (assert failure)

Post by David William » Sun, 22 Dec 2002 11:16:07




Quote:> Initializing rhead structure...succeeded
> Initializing ASF ...succeeded
> Initializing Dictionary Cache and SPL Routine Cache...

does it just stop there?

What does your $INFORMIXDIR/etc/$ONCONFIG contain (the full file)?
Any custom stuff like DS_HASH* and DD_HASH*?

What does
ldd $INFORMIXDIR/bin/oninit
 give? Try ldd with options to check all references
(normally ldd -r and then ldd -d but may be different on AIX).

Have you set kernel parameters as listed in the files under
$INFORMIXDIR/release
(Normally IDS_9.3 somewhere under there).??

Have you tried setting the

 
 
 

Help needed getting new IDS 9.3 installation working AIX 5.1 (assert failure)

Post by Constant Angular Veloci » Sun, 22 Dec 2002 21:38:27



> does it just stop there?

Yep - The assert failure presumably happens during the 'Initializing
Dictionary Cache and SPL Routine Cache' phase.

Quote:> What does your $INFORMIXDIR/etc/$ONCONFIG contain (the full file)?
> Any custom stuff like DS_HASH* and DD_HASH*?

The Onconfig is simply the unaltered onconfig for the demo database
(don't have it to hand but I can post it on Monday).

Quote:> What does
> ldd $INFORMIXDIR/bin/oninit
>  give? Try ldd with options to check all references
> (normally ldd -r and then ldd -d but may be different on AIX).

I'll check this on Monday.

Quote:> Have you set kernel parameters as listed in the files under
> $INFORMIXDIR/release
> (Normally IDS_9.3 somewhere under there).??

This is the bit which has troubled me! I'm used to setting up Informix
on HP-UX systems - where you won't get very far without setting myriad
kernel parameters. However, according to the AIX machine notes you
don't need to set any kernel parameters at all.. Is this true, AIX
Informix users ?!

I have been contacted by Informix tech support who say this has been
seen before and it was always down to bad distribution media, so
hopefully I'll get my hands on another distribution and see if it
fixes the problem..

Regards,
Ben

 
 
 

Help needed getting new IDS 9.3 installation working AIX 5.1 (assert failure)

Post by David William » Fri, 27 Dec 2002 09:30:46





Quote:> > does it just stop there?

> Yep - The assert failure presumably happens during the 'Initializing
> Dictionary Cache and SPL Routine Cache' phase.

> > What does your $INFORMIXDIR/etc/$ONCONFIG contain (the full file)?
> > Any custom stuff like DS_HASH* and DD_HASH*?

> The Onconfig is simply the unaltered onconfig for the demo database
> (don't have it to hand but I can post it on Monday).

  Try setting STMT_CACHE to 0 (to disable statment caching).
 
 
 

Help needed getting new IDS 9.3 installation working AIX 5.1 (assert failure)

Post by Constant Angular Veloci » Fri, 03 Jan 2003 20:22:34


David - just to let you know that I have now re-installed from the
replacement media and the engine came up first time without any
problems at all.. Annoying to have had a duff distribution, but at
least it's working now!

Thanks,
Ben

 
 
 

1. Best IDS 9.3 version for AIX 4.3

I am planining to upgrade my IDS WGE on AIX
What is the best (most stable) version of IBM Informix DS 9.3x for AIX 4.3.x?

Thanks

Nebojsa
------------------------------------
Remove spam block (DELETE) to reply

2. Execute SQL Output Param

3. IDS 7.31 on AIX 5.1

4. Eliminating trailing blanc lines on reports (fwd)

5. Array

6. IDS 7.31 on AIX 5.1?

7. Buying oracle

8. IDS.2000 9.21 and AIX 5.1

9. IDS 9.21 to IDS 9.3 upgrade

10. Difference(s) between IDS 7.23 and IDS 9.3

11. IDS 9.3 vs IDS.2000

12. Assert Failure on I-Star from 7.31 to 5.10