Sybase -ODBC -Access don't work

Sybase -ODBC -Access don't work

Post by Minna Granqvis » Wed, 29 Oct 1997 04:00:00



Hi,

Has anyone used the combination Sybase SQL Server - Sybase ODBC drive -
MS Access so that it work OK? If has, please tell me how.

I tryd those and they don't work. Access crash, 'Invalid page..', or
data in table is '#Deleted'.  

SQL Server 11.0.2.2 #6881 for NT
              |
Open Client 10.0.4 and Sybase ODBC 10.0.4
              |
Access 97 in Win95

OR

SQL Server 10.0.2.6 #6583 for Warp
    |
Open Client 10.0.4 and Sybase ODBC 10.0.4
      |
Access 97 Win95

Thanks,

Minna Granqvist

 
 
 

Sybase -ODBC -Access don't work

Post by Christof Schwa » Thu, 30 Oct 1997 04:00:00


Hi Minna

Quote:> Has anyone used the combination Sybase SQL Server - Sybase ODBC drive -
> MS Access so that it work OK? If has, please tell me how.

> I tryd those and they don't work. Access crash, 'Invalid page..', or
> data in table is '#Deleted'.

> SQL Server 11.0.2.2 #6881 for NT
>               |
> Open Client 10.0.4 and Sybase ODBC 10.0.4
>               |
> Access 97 in Win95

> OR

> SQL Server 10.0.2.6 #6583 for Warp
>     |
> Open Client 10.0.4 and Sybase ODBC 10.0.4
>       |
> Access 97 Win95

we had the same problem using SQL Server 11.02 for HPU-UX,
OpenClient 10.03 and ODBC 11.1 on WinNT 4.0

The combination OpenClient 11.1 (EBF 7398) and ODBC 11.1 didnt work.

I think the problem is the communication between OpenClient and
ODBC.

We tried OpenClient 10.04 (EBF 7437) and the ODBC Pack 3.01 for
Win95/NT (direct from Intersolv) and it works fine, no problems
with identity and inserts, no crashes of access.

Sybase said that their ODBC is exactly the same as the ODBC driver
from Intersolv. But why there are differents, no plan.

Bye,
        Christof

 
 
 

1. request working in access but don't work through ODBC

Hello
i developped a interface to communicate with databases
into our application using ODBC.

one of our scripter send my a bug.
the following request works in access but dosn't work
into our application which use ODBC :

INSERT INTO connected (clientid,dat) VALUES ('41', DATEADD
("h",1,NOW()))

but the following request works

INSERT INTO connected (clientid,dat) VALUES ('41',"h",1,NOW
())

so i think the problem came from DATEADD but i read some
documentation about it and it seems to be ok.

some one can help me ?
where can i found informations about this kind of problems
for the next time in accounter a problem like this.

thank you.

--
Nicolas Hognon

Virtools - The Behavior Company
Tel. (+33) 1 42 71 46 86 / Fax. (+33) 1 42 71 86 53
http://www.virtools.com/

2. PSQL2000 SDK Installation

3. MovePrevious don't work but the MoveNext work's fine

4. RelationClearRelation: relation X deleted while still in use???

5. Access and linked ODBC tables don't use ODBC Definition

6. xp_sendmail

7. Windows95 + TCP/IP + ODBC don't work

8. Announce: Altra release Micropoint Mouse Alternative, Kiss your Mouse Good-bye

9. Update Triggers from ODBC DON'T WORK!@#%&*

10. ODBC with Oracle IN OUT Parameters don't work

11. ODBC scalar functions don't work in heterogenous joins

12. ODBC with Oracle IN OUT Parameters don't work

13. COMPUTE clauses and ODBC don't work?