OAS 4.0.7.1 & Orb startup problem

OAS 4.0.7.1 & Orb startup problem

Post by kimptoc.m.. » Sun, 31 Dec 1899 09:00:00



I'm using SuSE6.3/Linux2.2.14/Oracle8i (8.1.5.0.2)

I've installed OAS4.0.7.1 and can get the node manager and related web
page started.
But when I try to start the rest of the servers (with owsctl start) -
it fails to start the Orb and says it should be started manually.

I've tried the following from previous posts...
- use the old ps
- upgrade to 4.0.7.1
- change the orb hostname
- increase user processes to 500+

I have 128mb ram/300mb swap - which doesn't seem to be fully used. So I
don't think that is a problem.

Any further ideas? Is 4.0.8.1 any better?

Thanks,
Chris

Sent via Deja.com http://www.deja.com/
Before you buy.

 
 
 

OAS 4.0.7.1 & Orb startup problem

Post by Hyper B Orea » Sun, 31 Dec 1899 09:00:00



Quote:> I'm using SuSE6.3/Linux2.2.14/Oracle8i (8.1.5.0.2)

> I've installed OAS4.0.7.1 and can get the node manager and related web
> page started.
> But when I try to start the rest of the servers (with owsctl start) -
> it fails to start the Orb and says it should be started manually.

> I've tried the following from previous posts...
> - use the old ps
> - upgrade to 4.0.7.1
> - change the orb hostname
> - increase user processes to 500+

> I have 128mb ram/300mb swap - which doesn't seem to be fully used. So I
> don't think that is a problem.

> Any further ideas? Is 4.0.8.1 any better?

yep. 4.0.7 on linux is a bug ridden piece of crap. 4.0.8.1/linux works -
just don't try to use ICX under linux, we found major bugs on that platform
using ICX, which meant we had to switch to NT. We still use the linux OAS
for a little development and small internal projects, but not major or
critical ones. ;-)

you should have 256MB however and user processes should be > 1024. OAS will
easily max out 128MB.

to use 4.0.8.1 you should have oracle db 8.0.6 or 8.1.5, and glibc 2.1 ...
4.0.7.x wants glibc 2.0 only. redhat 6.1 seems ok for 4.0.8.1.

hbo

 
 
 

1. Solution to OAS 4.0.7 ORB startup error

FYI
----

This is for all you guys who are getting the following message with OAS
4.0.7 running on NT 4.0 Server (SP4).

Please wait while the command is being processed on host location.
Starting ORB processes...
Returning filename c:\orant\orb\admin\.event
Waiting for ORB to be ready...
ORB is not responding. Please restart manually
OWS-2024 : The OAS processes can not be started because the
           CORBA ORB processes can not be started.

I had the same error. This is how I managed to solve it. You need to
install a patch. Go to the Oracle patch download site. Address is
ftp://oracle-ftp.oracle.com/server/patchsets/
internet/NT/oas40710/export/
Download the patch file and the patch notes file. Read the file for
instructions to install the patch. Installing the patch is real easy.
This error would be gone.

The patch also removes other bugs. The list is mentioned in the patch
notes file.

See ya guys

Rohit Nirvan

Sent via Deja.com http://www.deja.com/
Share what you know. Learn what you don't.

2. Running a batch of stored pocs

3. ORB problem with OAS 4.07 for NT

4. DBList Box Question

5. OAS 4.0.8 ECO/Java ORB problem ...

6. Liberty ODBC

7. Strange ORB problem, OAS 4.0.8.1

8. How to Execute a Prediction Query Over Analysis Services 2000?

9. OAS 4.0 ORB don't start

10. OAS 4.0.8.0.2a - Cannot start ORB process

11. OAS 4.07 ORB not starting and very slow

12. OAS 4.07 with ORB error--OWS20214

13. HELP: OAS 4.0.8.1 Linux - ORB is not responding