NLS_LANG Setting

NLS_LANG Setting

Post by Scarlett Y » Thu, 09 Jul 1998 04:00:00



Hello,
I have installed the Oracle8 client for Win NT and set the NLS_LANG to:
TRADITIONAL CHINESE_TAIWAN.ZHT16BIG5. The server is in Unix platform and  
the Oracle8 Server is set to:AMERICAN_AMERICA.US7ASCII.
        The problem is when I insert data, which are Chinese Character,
into the Oracle database through 'Oracle ODBC 32Bit Test', all the Chinese
Character become unknown symbol and Question mark(?). Can anyone know how
to soft this problem?

And I try the SQL statement in client side:
        select userenv('LANGUAGE') from dual
the result is:
        TRADITIONAL CHINESE_TAIWAN.US7ASCII
instead of:
        TRADITIONAL CHINESE_TAIWAN.ZHT16BIG5
Why they are different??? and How to soft this problem???
Thanks for your attention!

Regards,
Scarlett

 
 
 

NLS_LANG Setting

Post by Winnie Li » Thu, 09 Jul 1998 04:00:00


The chinese character is multi-byte character set while the American
character type is single-byte character. There is no way to see or store
multi-byte character using single-byte character server. The single-byte
character server will not recognize any of those multibyte chinese
character.

Winnie Liu


>Hello,
>I have installed the Oracle8 client for Win NT and set the NLS_LANG to:
>TRADITIONAL CHINESE_TAIWAN.ZHT16BIG5. The server is in Unix platform and
>the Oracle8 Server is set to:AMERICAN_AMERICA.US7ASCII.
> The problem is when I insert data, which are Chinese Character,
>into the Oracle database through 'Oracle ODBC 32Bit Test', all the Chinese
>Character become unknown symbol and Question mark(?). Can anyone know how
>to soft this problem?

>And I try the SQL statement in client side:
> select userenv('LANGUAGE') from dual
>the result is:
> TRADITIONAL CHINESE_TAIWAN.US7ASCII
>instead of:
> TRADITIONAL CHINESE_TAIWAN.ZHT16BIG5
>Why they are different??? and How to soft this problem???
>Thanks for your attention!

>Regards,
>Scarlett


 
 
 

1. Problem with Reports when NLS_LANG set

When running Reports 2.5.5.5 on SCO OpenServer5.5 I get an error
REP-3000: Internal error starting Oracle Toolkit. When NLS_LANG is
unset, the problem disappears as if by magic.

Any Ideas?

HAP 8^)

--
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
All that is visible must grow beyond itself
and extend into the reals of the invisible.
  -- Dumont, the tower guardian, _TRON_

Sent via Deja.com http://www.deja.com/
Share what you know. Learn what you don't.

2. Delphi 2 and Informix : sloooooooow !!!!!

3. 2 nls_lang settings on 1 client

4. Ingres wanted

5. NLS_LANG setting in registry results error ORA-01002 fetch out of sequence?!

6. replicate over 500 tables

7. Setting NLS_LANG on W2000

8. IUS: Datablades & portability

9. How to set NLS_LANG of a database?

10. HELP:Setting the NLS_LANG env parameter

11. Setting NLS_LANG env. variable

12. Re-setting NLS_LANG from C++/OCI app

13. Question setting languaje (NLS_LANG)