Problem: OLE automation server can't create object

Problem: OLE automation server can't create object

Post by H.Staak » Fri, 20 Feb 1998 04:00:00



When I'm trying to start my application on an other computer I get the
error (number 429):

        OLE automation server can't create object

This is on a computer with Windows'95 and it's an 16 bit Visual Basic 4
program.
On my own computer I have no problems.

I think it has something to do with then VB command: Set db=OpenDatabase
("FILE.MDB")

I read somewhere on the page of Microsoft I had to use the following
command on the DOS prompt:

REGSVR.EXE AUTPRX16.DLL

But I don't have these two files!

Does anybody know a solution.
Please Help Me (After searching the web for hours)

Answering please bij E-mail

H. Staaks


 
 
 

Problem: OLE automation server can't create object

Post by Richard Magea » Sun, 22 Feb 1998 04:00:00


did you create distribution media with the setup wizard?

any time you get an error 429, it means that an ole server (like the DAO
engine) wasn't registered properly, if at all, on the client machine.

check to make sure everything is being distrbuted properly!

--

Don't forget to check out our web page for more great hints!
www.xtremecomp.com


>When I'm trying to start my application on an other computer I get the
>error (number 429):

> OLE automation server can't create object

>This is on a computer with Windows'95 and it's an 16 bit Visual Basic 4
>program.
>On my own computer I have no problems.

>I think it has something to do with then VB command: Set db=OpenDatabase
>("FILE.MDB")

>I read somewhere on the page of Microsoft I had to use the following
>command on the DOS prompt:

>REGSVR.EXE AUTPRX16.DLL

>But I don't have these two files!

>Does anybody know a solution.
>Please Help Me (After searching the web for hours)

>Answering please bij E-mail

>H. Staaks




 
 
 

1. hit or miss - ole automation server can't create object

the subject is the error msg when executing the following opendatabase
command in vb4.0
Set DbVar = DBEngine.Workspaces(0).OpenDatabase("dbDSN.mdb")
the mystery is i created the program with the above code on my laptop (w98)
and it runs fine, vb 4.0 and access 97 but won't run on a nt workstation
that has both vb4.0 and access 97. the same references are there in the same
order. (standard ole types, ms dao 2.5/3.5 compatability library)
its hit or miss, other programs developed on the w98 machine run on the NT??
does this have something to do with how access, and vb are registered?

2. Reading SQL Server 2000 tables from AS400

3. OLE Automation Server Can't Create Object

4. Grid problem

5. error 429 - ole automation server can't create object

6. Is this possible ?

7. OLE Automation Server can't create object!?

8. retrieving data from stored procedure with ADO

9. OLE Automation Server cant create object error please help

10. Automation server can't create object

11. OLE automation in WOrd 97 but can't access MSO97.dll objects

12. sp_OACreate cannot create OLE Automation object

13. Problem with OLE Automation object in SPROC