Package&Deployment wizard problem

Package&Deployment wizard problem

Post by Davo » Fri, 14 Sep 2001 05:57:11



I've created my first app with VB6, and now I can't install it!
Package&deployment wizard creates 3 files: projectname.cab,
setup.exe and setup.lst. I've copied those files on CD.
When I start setup.exe on target computer, it says:
---------
   Invalid line in setup information file
   Section: Setup 1 files

--------
then installation stops.

I've tried on different systems (98/95) and computers, but nothing
changes. I didn't change anything in setup.lst.

Please help !

 
 
 

Package&Deployment wizard problem

Post by James Harge » Fri, 14 Sep 2001 12:28:26


Are you using a file called "printer.ico"? If so, you need to include it in
your package. When stepping through the PDW, you come to a form where you
can add files to the package. At that point you can browse to the file in
question and a copy of it will be included with your package. You can even
specify where it goes when installed on the target machine, but the default
is the app path.

hth

Jim


> I've created my first app with VB6, and now I can't install it!
> Package&deployment wizard creates 3 files: projectname.cab,
> setup.exe and setup.lst. I've copied those files on CD.
> When I start setup.exe on target computer, it says:
> ---------
>    Invalid line in setup information file
>    Section: Setup 1 files

> --------
> then installation stops.

> I've tried on different systems (98/95) and computers, but nothing
> changes. I didn't change anything in setup.lst.

> Please help !


 
 
 

Package&Deployment wizard problem

Post by Davo » Sat, 15 Sep 2001 05:36:06


Of course I'm using 'printer.ico' file. I've added it in PDW in the way you
kindly explained. But the problem is in installation, not creation of setup
files.
Thx again


> Are you using a file called "printer.ico"? If so, you need to include it
in
> your package. When stepping through the PDW, you come to a form where you
> can add files to the package. At that point you can browse to the file in
> question and a copy of it will be included with your package. You can even
> specify where it goes when installed on the target machine, but the
default
> is the app path.

> hth

> Jim



> > I've created my first app with VB6, and now I can't install it!
> > Package&deployment wizard creates 3 files: projectname.cab,
> > setup.exe and setup.lst. I've copied those files on CD.
> > When I start setup.exe on target computer, it says:
> > ---------
> >    Invalid line in setup information file
> >    Section: Setup 1 files

> > --------
> > then installation stops.

> > I've tried on different systems (98/95) and computers, but nothing
> > changes. I didn't change anything in setup.lst.

> > Please help !

 
 
 

Package&Deployment wizard problem

Post by James Harge » Sun, 16 Sep 2001 00:05:16


Okay, sorry if I insulted your intelligence, but the most frequent cause of
these problems is the failure to include needed files with the PDW. Another
is that the default location for the installed files is in the app path but
the exe was compiled with code referring to a different location.

Also, since you indicated that this is your first VB app, I thought we
should start with the obvious.

Jim


> Of course I'm using 'printer.ico' file. I've added it in PDW in the way
you
> kindly explained. But the problem is in installation, not creation of
setup
> files.
> Thx again



> > Are you using a file called "printer.ico"? If so, you need to include it
> in
> > your package. When stepping through the PDW, you come to a form where
you
> > can add files to the package. At that point you can browse to the file
in
> > question and a copy of it will be included with your package. You can
even
> > specify where it goes when installed on the target machine, but the
> default
> > is the app path.

> > hth

> > Jim



> > > I've created my first app with VB6, and now I can't install it!
> > > Package&deployment wizard creates 3 files: projectname.cab,
> > > setup.exe and setup.lst. I've copied those files on CD.
> > > When I start setup.exe on target computer, it says:
> > > ---------
> > >    Invalid line in setup information file
> > >    Section: Setup 1 files

> > > --------
> > > then installation stops.

> > > I've tried on different systems (98/95) and computers, but nothing
> > > changes. I didn't change anything in setup.lst.

> > > Please help !

 
 
 

Package&Deployment wizard problem

Post by David Wimbu » Tue, 18 Sep 2001 18:57:33



it's being added in the error message but, if that's how it looks in

after that.
 
 
 

1. Package & Deployment Wizard Problem

Hello All!

I got the following message while installing a Packaged VB Application into
a NT Workstation 4.0:

"The file 'C:\Winnt\System32\$(DLLSelfRegisterEx)' could not be registered
because it was not found".

Does anyone saw this message before and know how to fix it?
Do "Package & Deployment Wizard" (Visual Studio 6.0 new Setup Wizard) really
works?

My VB6 application have a lot of OCX controls and uses MDAC.

ANY help is very wellcome!!! Thank you!

Richard Chaves

2. Job - NY - Informix DBA [1/1]

3. package & Deployment Wizard

4. rebuild indexes

5. Package & Deployment Wizard

6. install Oracle8i or Oracle9i on Linux Mandrake8

7. Errors from VB6 Package & Deployment Wizard

8. navigation problems !!

9. Package & Deployment Wizard with SQL2000

10. Package & Deployment Wizard Query

11. Package & Deployment Wizard and Bitmaps

12. ADO 2.0 and Package/Deployment Wizard

13. Package and Deployment Wizard Error 743