VB4 and Office 97

VB4 and Office 97

Post by David De Bon » Wed, 22 Jan 1997 04:00:00



We have developed an application in VB4 using Access database 3.0.

When Office 97 is installed we get this message:

Can't open database created with a previous version of your application

We are using DAO 3.0.

 
 
 

VB4 and Office 97

Post by Brad Scarle » Thu, 23 Jan 1997 04:00:00


I had a similiar problem and had to go on an individual DLL and
support file basis for the Jet engine and determine what version was
installed on the hosting machone and what it should be and then
manually make the change.  It took about 2 hours but afterwords VB
apps ran fine.

brad



Quote:>We have developed an application in VB4 using Access database 3.0.

>When Office 97 is installed we get this message:

>Can't open database created with a previous version of your application

>We are using DAO 3.0.


 
 
 

VB4 and Office 97

Post by Aaron Lewi » Tue, 28 Jan 1997 04:00:00


Man... That's fine for us on the development side, but what about
distributed apps???  Hey Microsoft, are you people AWAKE???



> I had a similiar problem and had to go on an individual DLL and
> support file basis for the Jet engine and determine what version was
> installed on the hosting machone and what it should be and then
> manually make the change.  It took about 2 hours but afterwords VB
> apps ran fine.

> brad



> >We have developed an application in VB4 using Access database 3.0.

> >When Office 97 is installed we get this message:

> >Can't open database created with a previous version of your application

> >We are using DAO 3.0.

 
 
 

VB4 and Office 97

Post by David De Bon » Tue, 28 Jan 1997 04:00:00


What exactly did you do ?



Quote:> I had a similiar problem and had to go on an individual DLL and
> support file basis for the Jet engine and determine what version was
> installed on the hosting machone and what it should be and then
> manually make the change.  It took about 2 hours but afterwords VB
> apps ran fine.

> brad

 
 
 

1. Out of Stack 28 using VB4-32bit with Office 97 Installed

Has anyone run into the situation where a client is running a VB4-32bit
developed app using the MSJet DAO.DBengine Version 3.0/3.5 developed
database that comes with VB 4.0, where MS Office 97 Full version was
installed after the VB app was installed (Full version of Office included
MS Access 97) and Out of Stack 28 errors start to occur.  

I have a simple app that uses a local database.  It has been working fine
for the longest time.  The only change the client can think of was MS
Office 97 being installed, this included MS Access.  Does anyone know if
there is an updated MSJetDBengine DLL that comes with MS Access 97 that
would overwrite the 3.0/3.5 DBEngine DLL and cause a compatibility problem.

Any help would help.

Thanks.
Pete.....

2. Act! into Quickbooks

3. VB4 and Access 3.0 (Office 97)

4. B+ Tree code

5. Oracle Driver Problem VB4 to VB5 and Office 97

6. Startup the database automatically

7. VB4 and Access 3.0 (Office 97)

8. Stored procedure and temporary tables

9. Office 97 breaks vb4-32 application -- Error 3041

10. Office 97 and VB4.0

11. VB4 and MS Office 97

12. DAO Office '97 and VB4

13. Office 97 and VB4.0 Problems