Help : Remote OLE Automation Problem in 95 and NT 4.0

Help : Remote OLE Automation Problem in 95 and NT 4.0

Post by Nick L » Thu, 21 Nov 1996 04:00:00



Can anyone please help?

When I use RemAuto Connection Manager to register an Local OLE Server
(in 95)  to Remote, it report an error -> (An error occured writing to
the registery)  to me and can not  set it to remote. but when I use
Compoment Manager to install this server into my NT 4.0 server,it is
successful. but I still can't use it in my client program. It tell me
that OLE Automation Error ! Why ???

Thank you for helping me !

 
 
 

1. Using OLE Automation On 95 versus NT

I am having a weird problem in VB5 because when I run my program on
Windows 95 it works, and when I do it on NT Workstation
(4.0), it fails miserabe in that a program called Dr. Watson, which
is a debugging program of Visual Basic's comes up on the screen.

Can someone please help me out. I have included my code here:
Thanks, Vipul.

Oh by the way, Microsoft was quite puzzled by this as well.

VERSION 5.00
Begin VB.Form Form1
   Caption         =   "Form1"
   ClientHeight    =   3936
   ClientLeft      =   48
   ClientTop       =   276
   ClientWidth     =   7056
   LinkTopic       =   "Form1"
   ScaleHeight     =   3936
   ScaleWidth      =   7056
   StartUpPosition =   3  'Windows Default
   Begin VB.CommandButton Command1
      Caption         =   "Command1"
      Height          =   1332
      Left            =   1080
      TabIndex        =   0
      Top             =   1200
      Width           =   4332
   End
End
Attribute VB_Name = "Form1"
Attribute VB_GlobalNameSpace = False
Attribute VB_Creatable = False
Attribute VB_PredeclaredId = True
Attribute VB_Exposed = False
Dim myExcel As Excel.Application
Dim wb As Excel.Workbook

Dim ws As Excel.Worksheet

Private Sub Command1_Click()
Set myExcel = CreateObject("Excel.Application")
myExcel.WorkBooks.Open filename:="C:\PROJ1\LOG.XLS"
Set wb = myExcel.ActiveWorkBook
Set ws = wb.Sheets(1)
ws.Range("A5").Value = 99

myExcel.Visible = True
MsgBox "This Worked"

Set myExcel = Nothing
Set ws = Nothing
Set wb = Nothing

End Sub

2. Crazy Error on openWorkspace! Please help

3. Delphi 2.0, MS Schedule+ 95 and OLE Automation

4. empty tables ..

5. Help on OLE Automation (VB 4.0 to Excel 97)

6. Perl/Oracle problem with placeholders

7. Nt or 95, why is NT faster, How to speed up 95

8. REPOST: Comparison of whole records

9. BUG: NT 4.0 Beta 2 + VB 4.0 OLE Servers

10. JOB: US Visual Basic Developers (2) - VB/MS-Access/Win-NT/Win 95/OLE/MFC

11. OLE / Remote Automation - The Truth is out there !

12. Error opening Database under Win NT 4.0 and some Win 95