ADO Referece to 2.0 or 2.1 library

ADO Referece to 2.0 or 2.1 library

Post by Ericsso » Thu, 21 Sep 2000 04:00:00



I have vB6 and sp3 installed in my PC.  If I want to use ado to connect to
an access97 file.  Which one should be used?

By the way, My connection string should be "OLEDB 3.51 or 4.0"

I found the using 4.0 , the database can not be updated after the app. is
package and installed on a new PC.

Ericsson

 
 
 

1. ADO 2.0 to 2.1 library

After installing SP3 I removed the ActiveX ADO 2.0 library from a
project and replaced it with the new 2.1 library but I'm getting
immediate errors when I try and run, or debug the application. Setting
the library back to 2.0 solves the problem but I'm curious as to what
I'm missing here?

The MoveComplete method of any recordset (as below) produces the error.

Private Sub adodcDealers_MoveComplete(ByVal adReason As
ADODB.EventReasonEnum, ByVal pError As ADODB.Error, adStatus As
ADODB.EventStatusEnum, ByVal pRecordset As ADODB.Recordset)
adodcDealers.Caption = "Record: " &
CStr(adodcDealers.Recordset.AbsolutePosition)
End Sub

Regards
John Marr

2. question about memory -page faults

3. ADO Control against ADO 2.1 and ADO 2.0

4. insert LARGE amounts of text into a TEXT field - HOW?

5. Using ADO 2.1 / ADOX / ADO 2.0 with C++

6. Need to access DB using code only- please help!

7. ADO 2.0 vs ADO 2.1

8. Using ADO 2.1 / ADOX / ADO 2.0 with C++

9. Support regarding ADO 2.0, 2.1 and 2.5 with SQL 2000 SP1

10. ADO 2.0, 2.1, 2.5 support with SQL 2000 SP1

11. SQL7, ADO 2.0 or 2.1, and blank recordsets

12. ADO 2.0 and 2.1