P&D installation problem on NT Workstation: MSADO25.TBL could not registered

P&D installation problem on NT Workstation: MSADO25.TBL could not registered

Post by Rene Balver » Fri, 05 Apr 2002 03:33:27



Hello,

I've created an application with ADO. The target is W98 and NT4 Workstation,
but I am running VB on W2000.

When installing the software on a NT4 Workstation, the P&D install program
cannot register MSADO25.TBL. When I start the program, it exits with 'Could
not find (load) ActiveX object' or so.

On the W2000 machine, the reference in VB says: Microsoft Active Data
Objects 2.5 (when click on it, it says MSADO25.TBL).  When I get the
properties and look to the version info, it says ADO 2.6!!!

When I load the same VB project on NT WS, the MSADO2.5 is attached to
MSADO15.DLL and not to MSADO25.TBL.

The MSADO15.DLL on the W2000 machine is ADO 2.6, on the NT4 machine is ADO
2.5. When I create a P&D installation, it attached MDAC_TYP.EXE version 2.5
(and I've check MSADO15.DLL which is also 2.5).

I want to try to install MDAC 2.6 on the W2000 machine, and I hope that this
will put the MDAC 2.6 in the redist folder, but I'm not sure if it can help.

Is it wyse to install MDAC 2.6 on W98/NT4 machines, and are there any
pitfalls?

Thanks in advance,

Rene

 
 
 

P&D installation problem on NT Workstation: MSADO25.TBL could not registered

Post by Val Mazu » Fri, 05 Apr 2002 03:51:51


Hi,

Check next link about it

http://support.microsoft.com/directory/article.asp?
ID=KB;EN-US;Q299645&LN=EN-US&rnk=1&SD=msdn&FR=0&qry=Unable%
20to%20Register%
20MSADO15.TLB&src=DHCS_MSPSS_msdn_SRCH&SPR=MSALL&

Val

Quote:>-----Original Message-----
>Hello,

>I've created an application with ADO. The target is W98

and NT4 Workstation,
Quote:>but I am running VB on W2000.

>When installing the software on a NT4 Workstation, the
P&D install program
>cannot register MSADO25.TBL. When I start the program, it
exits with 'Could
>not find (load) ActiveX object' or so.

>On the W2000 machine, the reference in VB says: Microsoft
Active Data
>Objects 2.5 (when click on it, it says MSADO25.TBL).  
When I get the
>properties and look to the version info, it says ADO
2.6!!!

>When I load the same VB project on NT WS, the MSADO2.5 is
attached to
>MSADO15.DLL and not to MSADO25.TBL.

>The MSADO15.DLL on the W2000 machine is ADO 2.6, on the
NT4 machine is ADO
>2.5. When I create a P&D installation, it attached

MDAC_TYP.EXE version 2.5
Quote:>(and I've check MSADO15.DLL which is also 2.5).

>I want to try to install MDAC 2.6 on the W2000 machine,

and I hope that this
Quote:>will put the MDAC 2.6 in the redist folder, but I'm not

sure if it can help.

- Show quoted text -

Quote:

>Is it wyse to install MDAC 2.6 on W98/NT4 machines, and
are there any
>pitfalls?

>Thanks in advance,

>Rene

>.


 
 
 

P&D installation problem on NT Workstation: MSADO25.TBL could not registered

Post by Rene Balver » Fri, 05 Apr 2002 04:31:44


I've posted another question about ADO versions, I assume it is the best way
to update all workstation to 2.6, isn't it? BTW: my customers are using SQL7
or SQL2000.

Regards and thanks for your reply,

Rene


Quote:> Hi,

> Check next link about it

> http://support.microsoft.com/directory/article.asp?
> ID=KB;EN-US;Q299645&LN=EN-US&rnk=1&SD=msdn&FR=0&qry=Unable%
> 20to%20Register%
> 20MSADO15.TLB&src=DHCS_MSPSS_msdn_SRCH&SPR=MSALL&

> Val

> >-----Original Message-----
> >Hello,

> >I've created an application with ADO. The target is W98
> and NT4 Workstation,
> >but I am running VB on W2000.

> >When installing the software on a NT4 Workstation, the
> P&D install program
> >cannot register MSADO25.TBL. When I start the program, it
> exits with 'Could
> >not find (load) ActiveX object' or so.

> >On the W2000 machine, the reference in VB says: Microsoft
> Active Data
> >Objects 2.5 (when click on it, it says MSADO25.TBL).
> When I get the
> >properties and look to the version info, it says ADO
> 2.6!!!

> >When I load the same VB project on NT WS, the MSADO2.5 is
> attached to
> >MSADO15.DLL and not to MSADO25.TBL.

> >The MSADO15.DLL on the W2000 machine is ADO 2.6, on the
> NT4 machine is ADO
> >2.5. When I create a P&D installation, it attached
> MDAC_TYP.EXE version 2.5
> >(and I've check MSADO15.DLL which is also 2.5).

> >I want to try to install MDAC 2.6 on the W2000 machine,
> and I hope that this
> >will put the MDAC 2.6 in the redist folder, but I'm not
> sure if it can help.

> >Is it wyse to install MDAC 2.6 on W98/NT4 machines, and
> are there any
> >pitfalls?

> >Thanks in advance,

> >Rene

> >.

 
 
 

P&D installation problem on NT Workstation: MSADO25.TBL could not registered

Post by Val Mazu » Fri, 05 Apr 2002 05:44:02


Hi,

You can use both 2.6 and 2.7 it does not matter. 2.6 is 32
bit version, 2.7 is 64 bit

Val

Quote:>-----Original Message-----
>I've posted another question about ADO versions, I assume
it is the best way
>to update all workstation to 2.6, isn't it? BTW: my

customers are using SQL7
>or SQL2000.

>Regards and thanks for your reply,

>Rene



>> Hi,

>> Check next link about it

>> http://support.microsoft.com/directory/article.asp?
>> ID=KB;EN-US;Q299645&LN=EN-

US&rnk=1&SD=msdn&FR=0&qry=Unable%
Quote:>> 20to%20Register%
>> 20MSADO15.TLB&src=DHCS_MSPSS_msdn_SRCH&SPR=MSALL&

>> Val

>> >-----Original Message-----
>> >Hello,

>> >I've created an application with ADO. The target is W98
>> and NT4 Workstation,
>> >but I am running VB on W2000.

>> >When installing the software on a NT4 Workstation, the
>> P&D install program
>> >cannot register MSADO25.TBL. When I start the program,
it
>> exits with 'Could
>> >not find (load) ActiveX object' or so.

>> >On the W2000 machine, the reference in VB says:
Microsoft
>> Active Data
>> >Objects 2.5 (when click on it, it says MSADO25.TBL).
>> When I get the
>> >properties and look to the version info, it says ADO
>> 2.6!!!

>> >When I load the same VB project on NT WS, the MSADO2.5
is
>> attached to
>> >MSADO15.DLL and not to MSADO25.TBL.

>> >The MSADO15.DLL on the W2000 machine is ADO 2.6, on the
>> NT4 machine is ADO
>> >2.5. When I create a P&D installation, it attached
>> MDAC_TYP.EXE version 2.5
>> >(and I've check MSADO15.DLL which is also 2.5).

>> >I want to try to install MDAC 2.6 on the W2000 machine,
>> and I hope that this
>> >will put the MDAC 2.6 in the redist folder, but I'm not
>> sure if it can help.

>> >Is it wyse to install MDAC 2.6 on W98/NT4 machines, and
>> are there any
>> >pitfalls?

>> >Thanks in advance,

>> >Rene

>> >.

>.

 
 
 

P&D installation problem on NT Workstation: MSADO25.TBL could not registered

Post by Rene Balver » Fri, 05 Apr 2002 14:42:16


Thanks for your help, Val. I've posted this also in another message in the
group, but I didn't receive an answer yet.

On my new notebook with W2000 MSADO15.DLL has version 2.62.7926. I cannot
find any information about this version. When I install MDAC2.6, does is not
installer a lower version?

Rene


Quote:> Hi,

> You can use both 2.6 and 2.7 it does not matter. 2.6 is 32
> bit version, 2.7 is 64 bit

> Val

 
 
 

P&D installation problem on NT Workstation: MSADO25.TBL could not registered

Post by Val Mazu » Fri, 05 Apr 2002 21:19:43


Hi,

If you have some MDAC installrd on your PC, then you
cannot install version, which has less version number.
First you need to uninstall current version of MDAC. Check
next link to see how to uninstall MDAC

http://www.microsoft.com/data/MDAC21info/MDACinstQ.htm

Val

Quote:>-----Original Message-----
>Thanks for your help, Val. I've posted this also in

another message in the
Quote:>group, but I didn't receive an answer yet.

>On my new notebook with W2000 MSADO15.DLL has version
2.62.7926. I cannot
>find any information about this version. When I install

MDAC2.6, does is not
>installer a lower version?

>Rene



>> Hi,

>> You can use both 2.6 and 2.7 it does not matter. 2.6 is
32
>> bit version, 2.7 is 64 bit

>> Val

>.

 
 
 

P&D installation problem on NT Workstation: MSADO25.TBL could not registered

Post by Rene Balver » Sat, 06 Apr 2002 02:06:52


Hmmm, I'm a little bit afraid to install a lower version, my laptop is
working and I want to keep it that way.

I've created a P&D with ADO 2.6, but did not select the MDAC_TYP.EXE. On the
client PC's I install ADO 2.6, then 2.6 SP2, then my application. Everything
is working fine now.

And I'm still wondering where version 2.62.7926 came from... :-)

Rene


> Hi,

> If you have some MDAC installrd on your PC, then you
> cannot install version, which has less version number.
> First you need to uninstall current version of MDAC. Check
> next link to see how to uninstall MDAC

> http://www.microsoft.com/data/MDAC21info/MDACinstQ.htm

> Val

> >-----Original Message-----
> >Thanks for your help, Val. I've posted this also in
> another message in the
> >group, but I didn't receive an answer yet.

> >On my new notebook with W2000 MSADO15.DLL has version
> 2.62.7926. I cannot
> >find any information about this version. When I install
> MDAC2.6, does is not
> >installer a lower version?

> >Rene



> >> Hi,

> >> You can use both 2.6 and 2.7 it does not matter. 2.6 is
> 32
> >> bit version, 2.7 is 64 bit

> >> Val

> >.

 
 
 

P&D installation problem on NT Workstation: MSADO25.TBL could not registered

Post by Val Mazu » Sat, 06 Apr 2002 05:03:45


Hi,

I think SP2 changes version number

Val

Quote:>-----Original Message-----
>Hmmm, I'm a little bit afraid to install a lower version,
my laptop is
>working and I want to keep it that way.

>I've created a P&D with ADO 2.6, but did not select the

MDAC_TYP.EXE. On the
Quote:>client PC's I install ADO 2.6, then 2.6 SP2, then my

application. Everything
>is working fine now.

>And I'm still wondering where version 2.62.7926 came
from... :-)

>Rene



>> Hi,

>> If you have some MDAC installrd on your PC, then you
>> cannot install version, which has less version number.
>> First you need to uninstall current version of MDAC.
Check
>> next link to see how to uninstall MDAC

>> http://www.microsoft.com/data/MDAC21info/MDACinstQ.htm

>> Val

>> >-----Original Message-----
>> >Thanks for your help, Val. I've posted this also in
>> another message in the
>> >group, but I didn't receive an answer yet.

>> >On my new notebook with W2000 MSADO15.DLL has version
>> 2.62.7926. I cannot
>> >find any information about this version. When I install
>> MDAC2.6, does is not
>> >installer a lower version?

>> >Rene



>> >> Hi,

>> >> You can use both 2.6 and 2.7 it does not matter. 2.6
is
>> 32
>> >> bit version, 2.7 is 64 bit

>> >> Val

>> >.

>.

 
 
 

1. SQL 6.5 Workstation Installation Problem on NT 4.0 Workstation

Software

NT Workstation 4.0     with no Service Pack applied.
SQL 6.5 Workstation   with no Service Pack applied.

MS loopback installed.
No network card.
Use dynamic IP via ras to ISP.

Problem

After installing SQL on the E: drive,
Enterprise Manager does not see the (local) server and
cannot connect to it.

Solution

I installed SQL on the C: drive instead of the E: drive.
It works just fine. How aggrevating!
Apparently, SQL Workstation  will only install properly
on the C: drive.
I will report bug to MS.

2. Database application installations.

3. problems with installation of SQL Workstation 6.0 on NT Workstation 4.0

4. Menu and Pulldown Menu Features

5. ODBC Installation problem (Can not register msdadc.dll)

6. can DB-Lib and CT-Lib coexist?

7. Can't register local server running on NT 4.0 workstation

8. Access the database from a program

9. msado25.tlb register fails in setup program

10. Error registering msado25.tlb

11. Failed to register msado25.tlb

12. Cannot Register MSADO25.TLB

13. Failure to register msado25.tlb