data1.refresh error 525 "Data Access Error"

data1.refresh error 525 "Data Access Error"

Post by Wand » Fri, 20 Sep 2002 05:33:57



I am currectly connected to SQL server using ado. And I used the data
control (data1) to bound my recordset to a Grid. It is working
perfectly fine when it was running on my machine where Imy application
was developed. However, when I install it on a clean machine, I got
"Data Access Error", Error 525 when it execute "data1.refresh"

Notice that nothing is installed on the clean machine (including VB).
What have I missed out in my setup, I used wise install and the VB6
setup package. Neither one work. Please help.

Any help would be greatly appreciated.
Wanda

 
 
 

data1.refresh error 525 "Data Access Error"

Post by Val Mazu » Fri, 20 Sep 2002 20:35:57


Hi,

I think something missing in installation. Do you have Client tools for SQL
Server installed on that PC?

--
Val Mazur
Microsoft MVP


Quote:> I am currectly connected to SQL server using ado. And I used the data
> control (data1) to bound my recordset to a Grid. It is working
> perfectly fine when it was running on my machine where Imy application
> was developed. However, when I install it on a clean machine, I got
> "Data Access Error", Error 525 when it execute "data1.refresh"

> Notice that nothing is installed on the clean machine (including VB).
> What have I missed out in my setup, I used wise install and the VB6
> setup package. Neither one work. Please help.

> Any help would be greatly appreciated.
> Wanda


 
 
 

data1.refresh error 525 "Data Access Error"

Post by Wand » Sun, 22 Sep 2002 01:06:06


When I get rid of the "data" control (data1), everything works fine.
It must be some dll or tlb missing. As I mentioned earlier, for those
machines with VB installed, no error is arised.

Wanda


> Hi,

> I think something missing in installation. Do you have Client tools for SQL
> Server installed on that PC?

> --
> Val Mazur
> Microsoft MVP



> > I am currectly connected to SQL server using ado. And I used the data
> > control (data1) to bound my recordset to a Grid. It is working
> > perfectly fine when it was running on my machine where Imy application
> > was developed. However, when I install it on a clean machine, I got
> > "Data Access Error", Error 525 when it execute "data1.refresh"

> > Notice that nothing is installed on the clean machine (including VB).
> > What have I missed out in my setup, I used wise install and the VB6
> > setup package. Neither one work. Please help.

> > Any help would be greatly appreciated.
> > Wanda

 
 
 

data1.refresh error 525 "Data Access Error"

Post by Val Mazu » Sun, 22 Sep 2002 02:39:48


Try to prepare installation packahe using Package and Deployment Wizard from
Visual Studio. It should include all required DLL and other files into one
installation. Then run prepared installation on new PC.

--
Val Mazur
Microsoft MVP


> When I get rid of the "data" control (data1), everything works fine.
> It must be some dll or tlb missing. As I mentioned earlier, for those
> machines with VB installed, no error is arised.

> Wanda




> > Hi,

> > I think something missing in installation. Do you have Client tools for
SQL
> > Server installed on that PC?

> > --
> > Val Mazur
> > Microsoft MVP



> > > I am currectly connected to SQL server using ado. And I used the data
> > > control (data1) to bound my recordset to a Grid. It is working
> > > perfectly fine when it was running on my machine where Imy application
> > > was developed. However, when I install it on a clean machine, I got
> > > "Data Access Error", Error 525 when it execute "data1.refresh"

> > > Notice that nothing is installed on the clean machine (including VB).
> > > What have I missed out in my setup, I used wise install and the VB6
> > > setup package. Neither one work. Please help.

> > > Any help would be greatly appreciated.
> > > Wanda

 
 
 

data1.refresh error 525 "Data Access Error"

Post by Wand » Mon, 23 Sep 2002 19:03:40


I did use the Package and Deployment Wizard to bundle my application,
however, there is no luck, I still got the same error message.

Thanks.
Wanda


> Try to prepare installation packahe using Package and Deployment Wizard from
> Visual Studio. It should include all required DLL and other files into one
> installation. Then run prepared installation on new PC.

> --
> Val Mazur
> Microsoft MVP



> > When I get rid of the "data" control (data1), everything works fine.
> > It must be some dll or tlb missing. As I mentioned earlier, for those
> > machines with VB installed, no error is arised.

> > Wanda



> > > Hi,

> > > I think something missing in installation. Do you have Client tools for
>  SQL
> > > Server installed on that PC?

> > > --
> > > Val Mazur
> > > Microsoft MVP



> > > > I am currectly connected to SQL server using ado. And I used the data
> > > > control (data1) to bound my recordset to a Grid. It is working
> > > > perfectly fine when it was running on my machine where Imy application
> > > > was developed. However, when I install it on a clean machine, I got
> > > > "Data Access Error", Error 525 when it execute "data1.refresh"

> > > > Notice that nothing is installed on the clean machine (including VB).
> > > > What have I missed out in my setup, I used wise install and the VB6
> > > > setup package. Neither one work. Please help.

> > > > Any help would be greatly appreciated.
> > > > Wanda

 
 
 

data1.refresh error 525 "Data Access Error"

Post by Val Mazu » Tue, 24 Sep 2002 20:26:33


Hi,

Find that DLL file, which contains Data control, on your PC and copy it
manually to target PC. Then try to register it manually using Regsvr32
utility.

--
Val Mazur
Microsoft MVP


> I did use the Package and Deployment Wizard to bundle my application,
> however, there is no luck, I still got the same error message.

> Thanks.
> Wanda




> > Try to prepare installation packahe using Package and Deployment Wizard
from
> > Visual Studio. It should include all required DLL and other files into
one
> > installation. Then run prepared installation on new PC.

> > --
> > Val Mazur
> > Microsoft MVP



> > > When I get rid of the "data" control (data1), everything works fine.
> > > It must be some dll or tlb missing. As I mentioned earlier, for those
> > > machines with VB installed, no error is arised.

> > > Wanda



> > > > Hi,

> > > > I think something missing in installation. Do you have Client tools
for
> >  SQL
> > > > Server installed on that PC?

> > > > --
> > > > Val Mazur
> > > > Microsoft MVP



> > > > > I am currectly connected to SQL server using ado. And I used the
data
> > > > > control (data1) to bound my recordset to a Grid. It is working
> > > > > perfectly fine when it was running on my machine where Imy
application
> > > > > was developed. However, when I install it on a clean machine, I
got
> > > > > "Data Access Error", Error 525 when it execute "data1.refresh"

> > > > > Notice that nothing is installed on the clean machine (including
VB).
> > > > > What have I missed out in my setup, I used wise install and the
VB6
> > > > > setup package. Neither one work. Please help.

> > > > > Any help would be greatly appreciated.
> > > > > Wanda

 
 
 

data1.refresh error 525 "Data Access Error"

Post by Scot Ro » Wed, 25 Sep 2002 00:30:30


That file being the MSVBVM60.DLL which should be located in teh system 32 folder. Make sure the version on your development machine is the version you are
distributing to teh client (I have seen some really strange errors when the VB SP5 is installed and the Runtime from an earlier service pack is distributed.)

Scot Rose, MCSD
Microsoft Visual Basic Developer Support

Want to know more? Check out the MSDN at msdn.microsoft.com or the Microsoft Knowledge Base at support.microsoft.com

This posting is provided AS IS, with no warranties, and confers no rights.

 
 
 

1. Error 525 "Data Access Error"

I have a simple little VB4-16 database program that displays info from one
of two tables. To change tables, the user simply clicks an option button.
This has been working just fine until lately, when an error 525 is
generated after the user swaps tables several times (2 to 4 times
typically). I can't find error 525 in the trappable errors, so I only know
the ever-so-helpful text description included in the error dialog: Data
Access Error.

Any info on the error, or ideas on how to code a table switch safely?. The
app makes use of a data control.  TIA

2. Pervasive Control Center

3. VB6 Data Control + Microsoft Access (French) = Error 525 (Data Access Error)

4. SQL Server and Data Warehouse tools

5. RT Error 525 - 'Data Access error'

6. To Tom Kyte, about the book.

7. Data Access error 525???

8. Personal Oracle Runtime??

9. Data Access Error 525

10. Remote Connection Error "General Network Error"?

11. Sybase error: "SQL causing error :"

12. HELP: error C2065 "ERROR" undeclared identifier

13. Error "Unexpected error"?