PostgreSQL 7.1 Linux Installation

PostgreSQL 7.1 Linux Installation

Post by Paulo Parol » Fri, 02 Mar 2001 21:48:32



Dear Mirko,

Thanks for the reply. I have now PostgreSQL7.1 installed, but need to
re-install  package "php-pgsql-4.0.1pl2-9.i386.rpm". The installation
procedure reports me the following:

error: failed dependencies:
        libpq.so.2.1 is needed by php-pgsql-4.0.1pl2-9

And I have found the following files to exist on our system:


/usr/lib/libpq.so.2
/usr/lib/libpq.so.2.0
/usr/lib/libpq.so.2.1

Should I make some sort of symlink or perhaps force installation of
php-pgsql package? Can anybody give me some clue of how to procceed?

TIA,
Paulo Parola

----- Original Message -----


Sent: Thursday, February 22, 2001 7:20 PM
Subject: Re: [GENERAL] PostgreSQL 7.1 Linux Installation



> > error: failed dependencies:
> >         postgresql = 7.0.2 is needed by postgresql-server-7.0.2-17
> >         libpq.so.2.1 is needed by php-pgsql-4.0.1pl2-9
> >         libpq.so.2.1 is needed by postgresql-server-7.0.2-17


> > error: failed dependencies:
> >         postgresql = 7.1beta4 is needed by postgresql-server-7.1beta4-1
> >         libpq.so.2 is needed by postgresql-server-7.1beta4-1

> You have to specify both RPMs at once during the update:

> rpm -Uvh postgresql-server-7.1beta4-1.i386.rpm

postgresql-7.1beta4-1.i386.rpm

- Show quoted text -

> should do the trick, unless the beta-rpm does not provide a libpq.so.2.1
(at
> least with a build from CVS libpq.so.2.1 is installed, so I guess rpm is
> clever enough to provide this one as well). libpq.so.2 is just a symlink
to
> libpq.so.2.1

> Regards
> Mirko
> --

> http://sites.inka.de/picard/