Cannot build PL/Perl ...

Cannot build PL/Perl ...

Post by Adam Walczykiewi » Fri, 04 May 2001 05:41:08



Cannot build PL/Perl because libperl is not a shared library.
I'v got this error when I tried to compile PL/Perl.
I have SuSE Linux 7.0 , have I get a libperl.so library , and put it in
/usr /lib ...

Thanks for any help
Adam

--

---------------------------(end of broadcast)---------------------------
TIP 2: you can get off all lists at once with the unregister command

 
 
 

Cannot build PL/Perl ...

Post by Andy Ko » Fri, 04 May 2001 06:23:47



Quote:>Cannot build PL/Perl because libperl is not a shared library.
>I'v got this error when I tried to compile PL/Perl.
>I have SuSE Linux 7.0 , have I get a libperl.so library , and put it in
>/usr /lib ...

>Thanks for any help
>Adam

Hi Adam, I went through getting pl/perl working not too long ago - this
part of the docs talks about what you need to do.

http://www.ca.postgresql.org/users-lounge/docs/7.1/programmer/plperl....

By the way, if you intend to use perl functions with triggers - you should
be warned now that you can't - its not supported with 7.0. Although I don't
know about 7.1.

Andy.

---------------------------(end of broadcast)---------------------------
TIP 2: you can get off all lists at once with the unregister command


 
 
 

1. pl/perl won't build under 7.1.3

You need a dynamic library for dynamic extensions, you can't use a
static library.

--
Trond Eivind Glomsr?d
Red Hat, Inc.

---------------------------(end of broadcast)---------------------------
TIP 6: Have you searched our list archives?

http://archives.postgresql.org

2. Sorry For Double Posts

3. PL/Perl and Perl 5.8

4. TTable.Open to Oracle 7.1 Slooooow

5. What is SPL?

6. PL/PGSQL and PL/Perl time issues

7. Getting results into Visual Basic

8. Performance of c, pl/perl, pl/pgsql

9. Error in building perl interface

10. Building perl mods pg:PG or DBD:PG on non

11. building perl DBD::Informix on 9.21

12. Building WWW Databases using perl/CGI