suspect distribution agent and suspect merge agent ?

suspect distribution agent and suspect merge agent ?

Post by Frank de Vrie » Wed, 11 Aug 1999 04:00:00



I have two SQL Servers on different NT Servers. I made one server the
distribution server with one publication, which contains several articles.

I also set up a push subcription to the other SQL Server.

The following happens.
* A snapshot is generated succesfully
* After a while two errors occur. One at the publisher agent and one at the
merge agent:

'agent suspect: no response within 10 minutes'

In the target database i can't see a thing not even the table structures.

The two servers do nothing special, only running SQL Server and one of the
servers also runs IIS.

Does anyone have some suggestions for me?

Frank de Vries

 
 
 

suspect distribution agent and suspect merge agent ?

Post by Michael Hote » Thu, 12 Aug 1999 04:00:00


Stop the merge agent and restart it.

Mike

 
 
 

suspect distribution agent and suspect merge agent ?

Post by Frank de Vrie » Thu, 12 Aug 1999 04:00:00


I already tried to stop and restart it, but it failed to work. What was the
problem? I forgot to run Servicepack 1 on both servers and that was the
reason it didnt work. Now I don't have probems anymore.

Thanks for the suggestion.

Quote:> Stop the merge agent and restart it.

> Mike

 
 
 

1. Suspect distribution agent: possible causes?

Hi there,

I'm using push subscriptions from SQL Server 7 to 30 or so Jet databases through
ODBC. All databases are on the same box (NT4/SP4) as the publisher. Every
publication has one subscription and is by served by a snapshot agent and a
distribution agent.
Most of the subscriptions work fine, but for two of them the distribution agent
fails with one of these errors:

- 'agent suspect: no response within 10 minutes'. or
- another distribution agent is already running for this subscription. ...

I checked the agent history, SQL Server agent logs, BOL, but can't find any clue
about what may cause these errors.

I've removed the publications, cleaned up the REPLDATA\unc directory, deleted
and recreated the access databases, rebooted, recreated the publications and
subscriptions and still get the same errors on the same subscriptions!!!

Can someone tell me what's going on here? Maybe a corrupt distribution database?
If so, how can I fix it?

Thanx

2. Connection 7.0 SQL Server

3. Merge agent is suspect no activity from last 10 min

4. HPUX startup/shutdown script

5. Merge Agent Suspect?

6. Comparison between Oracle, Sybase, Ingres

7. Resuming a 'suspect' merge agent

8. SQL Server Archived logs

9. Merge Agent suspect.

10. Need your help on agent is suspect

11. Transact Replicaiton -- Log Reader Agent become suspect

12. Agent is Suspect Error

13. agent is suspect