Moving 6.5 database to another 6.5 database with different character set

Moving 6.5 database to another 6.5 database with different character set

Post by Bob Te » Fri, 13 Dec 2002 00:40:16



After moving a database to another server having a different character set
some problems occur. The application using the database is having problems
with some characters. The application did not have this problem with the
database on the original character set. I did the moving by doing a BCP out
from the original server and later doing a BCP in on the new server.
Does anyone know what to do to overcome this problem of moving databases to
another character set?Any help would be greatly appreciated.
 
 
 

Moving 6.5 database to another 6.5 database with different character set

Post by Erland Sommarsko » Fri, 13 Dec 2002 07:31:19



> After moving a database to another server having a different character
> set some problems occur. The application using the database is having
> problems with some characters. The application did not have this problem
> with the database on the original character set. I did the moving by
> doing a BCP out from the original server and later doing a BCP in on the
> new server. Does anyone know what to do to overcome this problem of
> moving databases to another character set?Any help would be greatly
> appreciated.

It would be far easier to address this, if you provided concrete
examples. What does sp_helpsort say on the two servers? And can you
give concreate examples of characters you are having problems with?

If you are asking for answer on the general case, that's an essay I
don't feel like writing...

--

I support PASS - the definitive global community for SQL Server
professionals - http://www.sqlpass.org