sql 2000 iis 5 ado database connection problem -- connections slow

sql 2000 iis 5 ado database connection problem -- connections slow

Post by Shane Lone » Thu, 27 Jun 2002 23:38:22



Hello everyone.  We're having a sporadic problem with our web application.
We have a test server set up with sql 2000 and iis 5 on 2000 server running
our web app.  After doing some things in the application (it doesn't seem to
matter which things) any link that runs a query will be really slow (8-15
seconds).  When I look at the queries through profiler it appears that what
is slowing me down is the disconnection of sql connections.  For instance in
the profiler I will have:  audit logout 10000ms.  Has anyone seen this
behavior before?  Any ideas?

PS - I saw the KB article about problems when connecting with ip -- we are
connecting with the host name.

 
 
 

sql 2000 iis 5 ado database connection problem -- connections slow

Post by Shane Lone » Fri, 28 Jun 2002 06:23:21


Never mind...the origin of the problem is web server related


Quote:> Hello everyone.  We're having a sporadic problem with our web application.
> We have a test server set up with sql 2000 and iis 5 on 2000 server
running
> our web app.  After doing some things in the application (it doesn't seem
to
> matter which things) any link that runs a query will be really slow (8-15
> seconds).  When I look at the queries through profiler it appears that
what
> is slowing me down is the disconnection of sql connections.  For instance
in
> the profiler I will have:  audit logout 10000ms.  Has anyone seen this
> behavior before?  Any ideas?

> PS - I saw the KB article about problems when connecting with ip -- we are
> connecting with the host name.


 
 
 

1. Win2000, IIS, , sql 2000, trusted connection problem - help

IIS 5 and SQL 2000 are on 2 separate boxes. SQL server named instance is set
to both SQL and win security. both boxes are in the same domain. the virtual
directory on the IIS server is set with both basic and Windows
authentication.
A domain account is created and added as a login to the SQL server and  user
to a database. ASP page is set to use a trusted connection. But the
connection to the SQL server does not happen.
I already spent sometime trying to figure this out, but without results. Are
there any issues I need to check, any settings I need to set, or could
someone suggest a way to to troubleshoot this ?
Thanks

2. AP SCO account to D3NT

3. Slow connection speed from ADO in IIS 4.0

4. Master/Detail Balance

5. SSL encrypted database connection between ASP (via ADO) and SQL Server 2000

6. DB2 with Tomcat

7. ADO.NET - SQL 2000 connection problem

8. What is _qb18.mb?

9. Orphaned Connections in SQL Server 2000 From IIS

10. Intermittently IIS drops connection to SQL Server 2000

11. Trusted connection between SQL Server 2000 and IIS 5.0

12. ADO Connection Problem and Windows 2000 - multiuser problem

13. IIS 5 / Oracle9i / ado connection problems