Merge Replication

Merge Replication

Post by Dejan Marki » Wed, 15 Jan 2003 16:51:25



Hello!

On master server I have tables like this: user.tablename ... when I try to
replicate those tables to secondary server they get names like dba.tablename
... how can I get rid of this? I won't them to be named user.tablename on
both servers? I guess I'm missing something obvious?

Thanks for your input!

--
Cheers,
Dejan
.oO(Change email TLD from .is to .si)
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

 
 
 

Merge Replication

Post by Amrit Birri » Thu, 16 Jan 2003 02:47:48



> Hello!

> On master server I have tables like this: user.tablename ... when I try to
> replicate those tables to secondary server they get names like dba.tablename
> ... how can I get rid of this? I won't them to be named user.tablename on
> both servers? I guess I'm missing something obvious?

> Thanks for your input!

I can give you one hint since I came across similar problem.
During the replication setup, one of the steps show you the
list of table names to be replicated at both
the source and destination databases. You can manually edit the
table names in the destination database tables list.

 
 
 

1. Message - No data needed to be merged - using merge replication

Can anyone help point me in the right direction?

I have set up merge replication of a database between two SQL2000 servers.

The publisher is running on a .NET server eval copy, I think its RC1.
Subscriber is on XP Pro. Both machines are in a workgroup, and I have set up
the same user to run the agents on both machines, and made sure that the
agent has access to all the relevant databases.

The problem is that while the initial snapshot was brought down to the
subscriber quite happily, no subsequent changes are being replicated.

When I look at the status of the agents, they always report "No data needed
to be merged".

I can see the agents running by looking at task manager, and I can see a
number of processes by looking at Current Activity in SQL enterprise
manager. I cant see any errors or anything that suggests a security problem,
it looks like its just not seeing the updates.

Anyone got any ideas as to what the problem may be?

2. bcp error during replication

3. Merge Replication : Merge Agent fails with Garbled sp name errors

4. MIS Manager Needed in Napa, CA

5. merge replication using Active X merge control

6. DSN - retrieve a list of

7. merge replication doesn't merge records

8. Updating a SQL Column to <null>

9. Merge Replication with ftp fails after adding A New Merge Article

10. Merge Replication, on-demand PULL replication

11. Replication fails over a VPN (Merge Replication)

12. Merge replication with identity value ranges using not for replication option

13. Merge Replication - Permissions Replication