SQL Server, Visual InterDev and ADO/ASP: one login works, another doesn't

SQL Server, Visual InterDev and ADO/ASP: one login works, another doesn't

Post by Rut » Sun, 08 Jul 2001 01:20:27



I'm setting up a database connection on my web site (IIS 4.0) using
Visual InterDev.  [InterDev runs on a development machine]  The
database is in MS SQL Server 7.0 and is located on a different machine
than the web server.

In SQL server I have created 2 logins WebAdmin and WebUser.  I have
also created 2 DSN's on the InterDev machine - one for WebAdmin and
one for WebUser using the ODBC found in the Control Panel.

I have 2 connections to my SQL database one using WebAdmin and one
using WebUser.

My code uses a SELECT statement to retrieve records from a table.

The code using the WebAdmin works and retrieves the records.  The code
using WebUser generates an error: ODBC Drivers error '80040e37' ...
Invalid object name ...

What am I doing wrong?

TIA

Ruth

 
 
 

SQL Server, Visual InterDev and ADO/ASP: one login works, another doesn't

Post by Zachary Well » Sun, 08 Jul 2001 01:17:25


Sounds like the WebUser is lacking some permissions. Do you have access to
the Query Analyzer? If so, log in as the WebUser and run the query to see
exactly where the problem is.

Zach


Quote:> I'm setting up a database connection on my web site (IIS 4.0) using
> Visual InterDev.  [InterDev runs on a development machine]  The
> database is in MS SQL Server 7.0 and is located on a different machine
> than the web server.

> In SQL server I have created 2 logins WebAdmin and WebUser.  I have
> also created 2 DSN's on the InterDev machine - one for WebAdmin and
> one for WebUser using the ODBC found in the Control Panel.

> I have 2 connections to my SQL database one using WebAdmin and one
> using WebUser.

> My code uses a SELECT statement to retrieve records from a table.

> The code using the WebAdmin works and retrieves the records.  The code
> using WebUser generates an error: ODBC Drivers error '80040e37' ...
> Invalid object name ...

> What am I doing wrong?

> TIA

> Ruth


 
 
 

1. New login creation doesn't work in SQL Server 2000

Dear SQL programmers,
I am trying to create a new login profile/identity in SQL Server 2000(90 day
trial), using XP professional.

I am using the standard code -
          sp_addlogin 'newuser'

which seems to be universally accepted as the correct syntax, but when I
start up Query Analyser, and choose SQL Server authentication I enter my
previously specified username, which doesn't require a password. But,
whatever I do I keep getting the message :

Login failed
Reason: Not associated with a trusted SQL Server connection.

2. Multiple Entries in a Field

3. CA-San Francisco-238944--Visual Basic-Scripting-COM-Visual InterDev-ASP-HTML-ADO

4. Insert into one row

5. ASP/SQL Server Problem, INSERT Works, UPDATE Doesn't

6. Delphi, TCP/IP, Oracle7

7. Porting ASP code from access to SQL Server - DSN doesn't work

8. Database sizing help

9. ASp's rs.Filter doesn't work for SQL

10. cant login to local SQL server on win98 via visual Interdev

11. Locking with adLockPessimistic (ADO) on SQL Server doesn't work