Sql Mail doesn't start!

Sql Mail doesn't start!

Post by Stefano Terenz » Fri, 20 Mar 1998 04:00:00



I cannot start the SQL Mail, each time i get the following message in
the error log:

17903 Mapi login Failure

For sure I was wrong in setting up something, but documentation doesn't
help me!
Where can I find out some documentation for setting up SQL Mail with
NT40!
Thank in advance!

 
 
 

Sql Mail doesn't start!

Post by Greg Mabl » Sat, 21 Mar 1998 04:00:00


The BOL has some documentation (chapter 18 in admin companion).  It also has
a trouble shooting section.  In order to help, can you tell me a little more
about your configuration?
Where is the the SQL Mail post office?
Did you setup a nt mail client on the sql server computer and run the mail
client to ensure that  you can send mail from the sql server computer?
What account is the sqlserver service running under?

--
Greg Mable
MCSE, MVP candidate (SQL server)
.exe Software, Inc.


>I cannot start the SQL Mail, each time i get the following message in
>the error log:

>17903 Mapi login Failure

>For sure I was wrong in setting up something, but documentation doesn't
>help me!
>Where can I find out some documentation for setting up SQL Mail with
>NT40!
>Thank in advance!


 
 
 

Sql Mail doesn't start!

Post by Walt Scot » Thu, 26 Mar 1998 04:00:00



> I cannot start the SQL Mail, each time i get the following message in
> the error log:

> 17903 Mapi login Failure

> For sure I was wrong in setting up something, but documentation doesn't
> help me!
> Where can I find out some documentation for setting up SQL Mail with
> NT40!
> Thank in advance!

Stefano,
I am also having problems getting SQLMail set-up.  The following is a
listing of the eror log I get on start-up or when I try to execute
xp_startmail.  I have tried the troubleshooting steps in the
Administrators Companion with no luck.  I am pretty sure it is something
with how the mail client on the server that is causing my problem.
Since the Administrators Companion instructions deal with NT3.51 and we
are running NT4.0 the instructions were not of much help to the Exchange
administrator.  

98/03/25 09:46:01.79 spid1    Launched startup procedure
'sp_sqlregister'
98/03/25 09:46:45.09 ods      Starting SQL Mail session...
98/03/25 09:46:45.10 ods      Error : 17903, Severity: 18, State: 1
98/03/25 09:46:45.10 ods      MAPI login failure.
98/03/25 09:46:45.10 ods      Error : 17951, Severity: 18, State: 1
98/03/25 09:46:45.10 ods      Failed to start SQL Mail session.
98/03/25 09:47:33.95 ods      Starting SQL Mail session...
98/03/25 09:47:33.96 ods      Error : 17903, Severity: 18, State: 1
98/03/25 09:47:33.96 ods      MAPI login failure.
98/03/25 09:47:33.96 ods      Error : 17951, Severity: 18, State: 1
98/03/25 09:47:33.96 ods      Failed to start SQL Mail session.
98/03/25 12:28:12.53 ods      Starting SQL Mail session...
98/03/25 12:28:12.55 ods      Error : 17903, Severity: 18, State: 1
98/03/25 12:28:12.55 ods      MAPI login failure.
98/03/25 12:28:12.55 ods      Error : 17951, Severity: 18, State: 1
98/03/25 12:28:12.55 ods      Failed to start SQL Mail session.

Any ideas would be appreciated.  Thanks.

 
 
 

Sql Mail doesn't start!

Post by Tibor Karasz » Fri, 27 Mar 1998 04:00:00


Walt,

I've found that these steps generally works:

Make sure that the MSSQLServer service uses a real account, not LocalSystem.
On the SQL Server machine, log on as the SQL Server service account.
Install the Exchange server client (or whatever it's called today), do not
use Windows Messaging.
Configure a profile, which is to be used by SQL Server.
Configure SQL Server to use that profile.
--

MCSE, MCSD, MCT, SQL Server MVP
Cornerstone Sweden AB

 
 
 

Sql Mail doesn't start!

Post by jb » Fri, 27 Mar 1998 04:00:00


Thanks Tibor! It Worked for me. Even using Microsoft Messaging.
jb

 
 
 

Sql Mail doesn't start!

Post by jb » Fri, 27 Mar 1998 04:00:00


Well...
A small bug. In order to start SQL Mail, I must always:
1. Log on as the SQL Server service account
2. Start Microsoft Messaging
3. Enterprise Manager | Configure SQL Mail |  Accept the default login
profile
4. Start Mail

At this point I can log back on to NT under my user account and SQL Mail
will be running. BUT if I stop the service I cannot restart it until I log
back on  as the SQL Server service account.
Any thoughts about this?

jb



Quote:> Thanks Tibor! It Worked for me. Even using Microsoft Messaging.
> jb

 
 
 

Sql Mail doesn't start!

Post by Tibor Karasz » Sat, 28 Mar 1998 04:00:00


Could be Win Messaging. I've heard that NT4 sp3 did some improvements with
Win Messaging, but I'm not sure it it handles this one...

--

MCSE, MCSD, MCT, SQL Server MVP
Cornerstone Sweden AB


>Well...
>A small bug. In order to start SQL Mail, I must always:
>1. Log on as the SQL Server service account
>2. Start Microsoft Messaging
>3. Enterprise Manager | Configure SQL Mail |  Accept the default login
>profile
>4. Start Mail

>At this point I can log back on to NT under my user account and SQL Mail
>will be running. BUT if I stop the service I cannot restart it until I log
>back on  as the SQL Server service account.
>Any thoughts about this?

>jb



>> Thanks Tibor! It Worked for me. Even using Microsoft Messaging.
>> jb