Copying Data

Copying Data

Post by C.Fleur » Thu, 25 Oct 2001 10:10:07



Hi,
For some reason I can no longer copy data in between my 2 SQL servers. I
keep getting failures and it doesn't matter which data base and tables I'm
attempting to copy. Both servers are development only and I'm the only user.
Any ideas ?

Thanks

C.Fleury

 
 
 

Copying Data

Post by Tom Morea » Thu, 25 Oct 2001 20:04:48


What troubleshooting have you done thus far?  Have you checked connectivity
issues?  Can you ping it?  Have chares been dropped?  Does your user ID have
permissions or have they been removed or denied?

--
   Tom

----------------------------------------------------------
Thomas A. Moreau, BSc, PhD, MCSE, MCDBA, MCT
SQL Server MVP
Columnist, SQL Server Professional

Toronto, ON Canada
www.pinnaclepublishing.com/sql
www.apress.com
---
Hi,
For some reason I can no longer copy data in between my 2 SQL servers. I
keep getting failures and it doesn't matter which data base and tables I'm
attempting to copy. Both servers are development only and I'm the only user.
Any ideas ?

Thanks

C.Fleury

 
 
 

Copying Data

Post by C.Fleur » Thu, 25 Oct 2001 20:35:02


Tom,
I'm the owner and sole user of the databases in both computers. Actually the
ONLY user having access to the computers. Also, after I wrote the message I
realized that even copying data across databases in the same server is
giving me the same error.

Thanks

C.Fleury


Quote:> What troubleshooting have you done thus far?  Have you checked
connectivity
> issues?  Can you ping it?  Have chares been dropped?  Does your user ID
have
> permissions or have they been removed or denied?

> --
>    Tom

> ----------------------------------------------------------
> Thomas A. Moreau, BSc, PhD, MCSE, MCDBA, MCT
> SQL Server MVP
> Columnist, SQL Server Professional

> Toronto, ON Canada
> www.pinnaclepublishing.com/sql
> www.apress.com

 
 
 

Copying Data

Post by Tom Morea » Fri, 26 Oct 2001 07:14:23


OK.  When you said "copying", I interpreted that literally.  Are you using
NT security or SQL Server security?  Under which account is SQL Server
running?  Are you sure you are logged as sa or a member of sysadmin?  Have
you got some sample code you can show us?

--
   Tom

----------------------------------------------------------
Thomas A. Moreau, BSc, PhD, MCSE, MCDBA, MCT
SQL Server MVP
Columnist, SQL Server Professional

Toronto, ON Canada
www.pinnaclepublishing.com/sql
www.apress.com
---
Tom,
I'm the owner and sole user of the databases in both computers. Actually the
ONLY user having access to the computers. Also, after I wrote the message I
realized that even copying data across databases in the same server is
giving me the same error.

Thanks

C.Fleury


Quote:> What troubleshooting have you done thus far?  Have you checked
connectivity
> issues?  Can you ping it?  Have chares been dropped?  Does your user ID
have
> permissions or have they been removed or denied?

> --
>    Tom

> ----------------------------------------------------------
> Thomas A. Moreau, BSc, PhD, MCSE, MCDBA, MCT
> SQL Server MVP
> Columnist, SQL Server Professional

> Toronto, ON Canada
> www.pinnaclepublishing.com/sql
> www.apress.com

 
 
 

Copying Data

Post by C.Fleur » Fri, 26 Oct 2001 07:47:20


Tom,
Here are the answers:
1. Are you using NT security or SQL Server security?
    SQL Server security,
2. Under which account is SQL Server running?
    Sorry....don't understand the question....
3. Are you sure you are logged as sa or a member of sysadmin?
    Member of sysadmin

The copying operation that keeps failing (It was working FINE before !!!!)
was:
Source->Office to Target->Home, but when I got to my office today I
attempted to transfer Office->Home and it worked fine......I'm totally
frustrated over this....

Thanks
C.Fleury


> OK.  When you said "copying", I interpreted that literally.  Are you using
> NT security or SQL Server security?  Under which account is SQL Server
> running?  Are you sure you are logged as sa or a member of sysadmin?  Have
> you got some sample code you can show us?

> --
>    Tom

> ----------------------------------------------------------
> Thomas A. Moreau, BSc, PhD, MCSE, MCDBA, MCT
> SQL Server MVP
> Columnist, SQL Server Professional

> Toronto, ON Canada
> www.pinnaclepublishing.com/sql
> www.apress.com
> ---

> Tom,
> I'm the owner and sole user of the databases in both computers. Actually
the
> ONLY user having access to the computers. Also, after I wrote the message
I
> realized that even copying data across databases in the same server is
> giving me the same error.

> Thanks

> C.Fleury



> > What troubleshooting have you done thus far?  Have you checked
> connectivity
> > issues?  Can you ping it?  Have chares been dropped?  Does your user ID
> have
> > permissions or have they been removed or denied?

> > --
> >    Tom

> > ----------------------------------------------------------
> > Thomas A. Moreau, BSc, PhD, MCSE, MCDBA, MCT
> > SQL Server MVP
> > Columnist, SQL Server Professional

> > Toronto, ON Canada
> > www.pinnaclepublishing.com/sql
> > www.apress.com

 
 
 

Copying Data

Post by Tom Morea » Fri, 26 Oct 2001 07:57:51


SQL Server runs as a service under NT.  Are you running it under a domain
account or under Local System?  You can go into Enterprise Manager, right
click on the server and select properties.  Then, click on the security tab.

I assume this is a DTS data pump of some kind.  Are both of these SQL
Servers?  What did you tell it for your authentication (check the properties
for each connection)?  Have you changed your password lately?

Are you able to log in through Query Analyzer?  Can you run a trace through
the Profiler?

--
   Tom

----------------------------------------------------------
Thomas A. Moreau, BSc, PhD, MCSE, MCDBA, MCT
SQL Server MVP
Columnist, SQL Server Professional

Toronto, ON Canada
www.pinnaclepublishing.com/sql
www.apress.com
---
Tom,
Here are the answers:
1. Are you using NT security or SQL Server security?
    SQL Server security,
2. Under which account is SQL Server running?
    Sorry....don't understand the question....
3. Are you sure you are logged as sa or a member of sysadmin?
    Member of sysadmin

The copying operation that keeps failing (It was working FINE before !!!!)
was:
Source->Office to Target->Home, but when I got to my office today I
attempted to transfer Office->Home and it worked fine......I'm totally
frustrated over this....

Thanks
C.Fleury


> OK.  When you said "copying", I interpreted that literally.  Are you using
> NT security or SQL Server security?  Under which account is SQL Server
> running?  Are you sure you are logged as sa or a member of sysadmin?  Have
> you got some sample code you can show us?

> --
>    Tom

> ----------------------------------------------------------
> Thomas A. Moreau, BSc, PhD, MCSE, MCDBA, MCT
> SQL Server MVP
> Columnist, SQL Server Professional

> Toronto, ON Canada
> www.pinnaclepublishing.com/sql
> www.apress.com
> ---

> Tom,
> I'm the owner and sole user of the databases in both computers. Actually
the
> ONLY user having access to the computers. Also, after I wrote the message
I
> realized that even copying data across databases in the same server is
> giving me the same error.

> Thanks

> C.Fleury



> > What troubleshooting have you done thus far?  Have you checked
> connectivity
> > issues?  Can you ping it?  Have chares been dropped?  Does your user ID
> have
> > permissions or have they been removed or denied?

> > --
> >    Tom

> > ----------------------------------------------------------
> > Thomas A. Moreau, BSc, PhD, MCSE, MCDBA, MCT
> > SQL Server MVP
> > Columnist, SQL Server Professional

> > Toronto, ON Canada
> > www.pinnaclepublishing.com/sql
> > www.apress.com

 
 
 

1. Copy Command Doesnt Copy Data

I have two databases that are the same one that has populated data in
the tables the other that does not.  Im trying to copy the data from
one of the tables into the new database.  I use the Enterprise Manager
to select the source table then do an Export to the new table
specifying the server and valid login credentials.  The process
appears to run fine but there is no data in the destination table.  I
have tried using the Copy Data and Append Data option with no luck.
It seems so straight forward and appears to run but not data in the
destination.
Any ideas??

Thanks
KW

-----= Posted via Newsfeeds.Com, Uncensored Usenet News =-----
http://www.newsfeeds.com - The #1 Newsgroup Service in the World!
-----==  Over 80,000 Newsgroups - 16 Different Servers! =-----

2. 4gl_install: execute permission denied

3. Can't copy data from data list into datagrid

4. minimize table locks

5. copy data structure and data

6. Good books T-SQL

7. Copy Data Structures no data DB to DB

8. FMP and internet: lasso, cdml or php? (i've got a budget of only 1500 us dollars)

9. Copying data into another database

10. Copying data from SQL to Oracle

11. Stored Procedures - copy data from one table to another

12. Best Way To Copy Data From One Table to another in the same database

13. DTS didn't copy data to source table