Porting ASP code from access to SQL Server - DSN doesn't work

Porting ASP code from access to SQL Server - DSN doesn't work

Post by B. Larso » Fri, 31 Jul 1998 04:00:00



We created a system DSN for an Access database and it works fine. We used
ASP code with embedded SQL statements. We ported the application to SQL
server and now get the following error:  

Microsoft OLE DB Provider for ODBC Drivers error '80004005'

[Microsoft][ODBC SQL Server Driver][SQL Server] Login failed

/TechSsecurity.inc, line 60

Any ideas on how to make it work would be greatly appreciated.

-Ben and Jennifer

 
 
 

Porting ASP code from access to SQL Server - DSN doesn't work

Post by Michael Welcom » Fri, 31 Jul 1998 04:00:00


Dear B. Larson,

I suspect that the problem you are having is due to differences in the ODBC
connect string required with SQL Server.  In access you dont have to include
the user ID and password to connect.  In SQL Server you do.  You will have
to update the ASP code to send the correct connect string.

Regards,

Michael Welcome

check out  http://www.sqltech.com


>We created a system DSN for an Access database and it works fine. We used
>ASP code with embedded SQL statements. We ported the application to SQL
>server and now get the following error:

>Microsoft OLE DB Provider for ODBC Drivers error '80004005'

>[Microsoft][ODBC SQL Server Driver][SQL Server] Login failed

>/TechSsecurity.inc, line 60

>Any ideas on how to make it work would be greatly appreciated.

>-Ben and Jennifer


 
 
 

1. SQL Server, Visual InterDev and ADO/ASP: one login works, another doesn't

I'm setting up a database connection on my web site (IIS 4.0) using
Visual InterDev.  [InterDev runs on a development machine]  The
database is in MS SQL Server 7.0 and is located on a different machine
than the web server.

In SQL server I have created 2 logins WebAdmin and WebUser.  I have
also created 2 DSN's on the InterDev machine - one for WebAdmin and
one for WebUser using the ODBC found in the Control Panel.

I have 2 connections to my SQL database one using WebAdmin and one
using WebUser.

My code uses a SELECT statement to retrieve records from a table.

The code using the WebAdmin works and retrieves the records.  The code
using WebUser generates an error: ODBC Drivers error '80040e37' ...
Invalid object name ...

What am I doing wrong?

TIA

Ruth

2. lock record

3. ASP/SQL Server Problem, INSERT Works, UPDATE Doesn't

4. ADO!HELP! How using tempory local Table with ADO - SQL-SERVER.

5. ASp's rs.Filter doesn't work for SQL

6. error lookup

7. Query built in Access doesn't work in SQL Server

8. US-NC-PL/SQL SKILLS NEEDED IN CHARLOTTE, NC

9. Query doesn't work after migrating from Access to SQL Server 7

10. Why doesn't this code work on my Win2k Server

11. SQL Mail doesn't work but SQLAgentMail works on prod server

12. ORACLE DOESN'T COMPLY TO BASIC STANDARD SQL: SIMPLE QUERIES DOESN'T WORK

13. sql enterprise manger's rigester server doesn't work in a nt workstation