ISDN PRI (E1) and analog calls

ISDN PRI (E1) and analog calls

Post by Arnold Mazu » Sun, 01 Jul 2001 02:42:06



Hello.
I read documentation CD, and I lost!
This weekend I have to learn a lot!

I bought C3640 with two Network Modules:
 - first has two E1 controllers and Fast Ethernet,
 - second has 30 modems on board.

I configured dialin service for ISDN modems using ppp encapsulation. It
works. But I would like to make analog calls to my router. It doesn't work!

Now I have "line bussy" signal. In the documentation is written about R1
signaling. Shoul I use them?
There in no command to do this in "int cont e1" configuration - wrong
software?

I have no idea how to put to work togheter 30 terminal lines and 30 serial
interfaces (B-channels).
Maybe I have wrong IOS? What should I check for ?

Maybe I should change something in my telecom provider?

Arnold.

 
 
 

ISDN PRI (E1) and analog calls

Post by Gareth Hinto » Sun, 01 Jul 2001 17:07:43


You can start by having a look through the basic config below if you like.
Do you have a Group-Async Interface attached?

Regards,

Gaz

!
hostname Router-1
!
enable secret ***************
!
username ******* password 0 ********

!
!
!
!
modem country mica united-kingdom
ip subnet-zero
no ip domain-lookup
!
isdn switch-type primary-net5
isdn voice-call-failure 0
chat-script offhook "" "ATH1" OK
chat-script dial ABORT ERROR "" "ATDT \T" TIMEOUT 30 CONNECT \c
!
!
controller E1 1/0
 pri-group timeslots 1-31
!
!
interface FastEthernet1/0
 ip address 172.20.1.241 255.255.255.0
 no ip directed-broadcast
 duplex auto
 speed auto
 no shut
!
interface Serial1/0:15
 ip address 172.20.5.1 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 dialer idle-timeout 30
 dialer map ip 172.20.5.2 name Router-2 broadcast 12345678
 dialer-group 1
 autodetect encapsulation ppp v120
 isdn switch-type primary-net5
 isdn incoming-voice modem
 fair-queue 64 256 0
 ppp callback accept
 ppp authentication chap pap
 no shut
!
interface Group-Async1
 ip unnumbered FastEthernet1/0
 no ip directed-broadcast
 encapsulation ppp
 async default routing
 async mode interactive
 peer default ip address pool dial-in
 no cdp enable
 ppp callback accept
 ppp authentication pap
 group-range 1 30
 no shut
!
router eigrp 666
 network 172.19.0.0
 network 172.20.0.0
!
ip local pool dial-in 172.20.7.1 172.20.7.30
ip classless
ip route 172.20.6.0 255.255.255.0 172.20.5.2
no ip http server
!
access-list 31 permit *********************
access-list 101 deny   eigrp any any
access-list 101 deny   udp any any eq snmptrap
access-list 101 deny   udp any any eq snmp
access-list 101 deny   udp any host 255.255.255.255
access-list 101 deny   ip any host 255.255.255.255
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101
snmp-server engineID local 00000009020000B06403E430
snmp-server community ******** RO 31
snmp-server community ******** RW 31
snmp-server enable traps isdn call-information
snmp-server enable traps isdn layer2
snmp-server host ************* **********
!
line con 0
 exec-timeout 0 0
 password *******
 transport input none
line 1 30
 autoselect ppp
 script modem-off-hook offhook
 script callback dial
 login local
 modem InOut
 modem autoconfigure type mica
 transport input all
line aux 0
line vty 0 4
 password ***************
 login
!
end

Quote:> Hello.
> I read documentation CD, and I lost!
> This weekend I have to learn a lot!

> I bought C3640 with two Network Modules:
>  - first has two E1 controllers and Fast Ethernet,
>  - second has 30 modems on board.

> I configured dialin service for ISDN modems using ppp encapsulation. It
> works. But I would like to make analog calls to my router. It doesn't
work!

> Now I have "line bussy" signal. In the documentation is written about R1
> signaling. Shoul I use them?
> There in no command to do this in "int cont e1" configuration - wrong
> software?

> I have no idea how to put to work togheter 30 terminal lines and 30 serial
> interfaces (B-channels).
> Maybe I have wrong IOS? What should I check for ?

> Maybe I should change something in my telecom provider?

> Arnold.


 
 
 

ISDN PRI (E1) and analog calls

Post by Arnold Mazu » Sun, 01 Jul 2001 17:32:14




Quote:> You can start by having a look through the basic config below if you like.
> Do you have a Group-Async Interface attached?

....

It looks fine. I haven't used Group-Async interface yet. I try it at Monday.

Thanks.

 
 
 

ISDN PRI (E1) and analog calls

Post by zhe » Mon, 02 Jul 2001 08:29:44


I think the configuration tasts include:
.Enable CAS on your E1 controler using "cont e1" and "cas-group" commands
.Create the asynchronous interface group using "int group-async" command
.Configure the modem lines for dial(in &/ out)
.Configure the IP pool

Good luck.

---zher


> Hello.
> I read documentation CD, and I lost!
> This weekend I have to learn a lot!

> I bought C3640 with two Network Modules:
>  - first has two E1 controllers and Fast Ethernet,
>  - second has 30 modems on board.

> I configured dialin service for ISDN modems using ppp encapsulation. It
> works. But I would like to make analog calls to my router. It doesn't work!

> Now I have "line bussy" signal. In the documentation is written about R1
> signaling. Shoul I use them?
> There in no command to do this in "int cont e1" configuration - wrong
> software?

> I have no idea how to put to work togheter 30 terminal lines and 30 serial
> interfaces (B-channels).
> Maybe I have wrong IOS? What should I check for ?

> Maybe I should change something in my telecom provider?

> Arnold.

 
 
 

ISDN PRI (E1) and analog calls

Post by Arnold Mazu » Mon, 02 Jul 2001 17:12:29


But I have no cas-group command in "interface e1" configuration.
When I have load IOS to  the Flash I used image without "t" letter on th enf
of its file name.
Maybe its a mistake?
I dokumentation is written:
....
"CAS is call signaling that is configured on an E1 controller and enables
the access server to send or receive analog calls. The signaling uses
the16th channel (time slot); thus, CAS fits in the out-of-band signaling
category.

To configure the E1 controllers in the Cisco AS5200 access server, use the
following commands beginning in global configuration mode:
...
Step 2: cas-group channel-number
             timeslots range type signal
                                                             Configures CAS
and the R2 signaling protocol on a specified number
                                                              of time
slots."

Y have probably right. I have to use CAS. But I have no commands to it. The
few lines abowe, talk about AS5200. What about C3640?

Thanks.



> I think the configuration tasts include:
> .Enable CAS on your E1 controler using "cont e1" and "cas-group" commands
> .Create the asynchronous interface group using "int group-async" command
> .Configure the modem lines for dial(in &/ out)
> .Configure the IP pool

> Good luck.

> ---zher




Quote:> > Hello.
> > I read documentation CD, and I lost!
> > This weekend I have to learn a lot!

> > I bought C3640 with two Network Modules:
> >  - first has two E1 controllers and Fast Ethernet,
> >  - second has 30 modems on board.

> > I configured dialin service for ISDN modems using ppp encapsulation. It
> > works. But I would like to make analog calls to my router. It doesn't
work!

> > Now I have "line bussy" signal. In the documentation is written about R1
> > signaling. Shoul I use them?
> > There in no command to do this in "int cont e1" configuration - wrong
> > software?

> > I have no idea how to put to work togheter 30 terminal lines and 30
serial
> > interfaces (B-channels).
> > Maybe I have wrong IOS? What should I check for ?

> > Maybe I should change something in my telecom provider?

> > Arnold.

 
 
 

ISDN PRI (E1) and analog calls

Post by Mortimer Mou » Tue, 03 Jul 2001 19:53:14


Configs would be nice - don't know where to start...

Try configuring "incoming-voice modem" to the E1 line's Sx/y:15
interface.  E.g. for the first E1 in slot1

int S1/0:15
  incoming-voice modem

this will tell IOS to divert incoming voice calls to the internal
modems.

Next ensure that you have some of the physical lines assigned to a
GroupAsync interface.  Your physical lines should be enabled for
either dialin, dialout, or inout, depending on what you're trying to
do.  The physical line numbering for modems on a 3600 series router
depend on the slot they are installed in - check

http://www.cisco.com/warp/public/471/108.html

for how to work out the numbers.  For a 30 modem module in slot 2,
which you want to enable for dial-in and dial-out, configure

line 65 96
  modem inout

Beyond here, there's tons of further configuration depending on what
you want to do.  Check out the dial configuration guide (I know - you
already have and it beat you!) but beware that Cisco changed the

 
 
 

ISDN PRI (E1) and analog calls

Post by Mortimer Mou » Tue, 03 Jul 2001 19:55:03


Reposted because Google truncated the posting somehow.  Sorry.

Configs would be nice - don't know where to start...

Try configuring "incoming-voice modem" to the E1 line's Sx/y:15
interface.  E.g. for the first E1 in slot1

int S1/0:15
  incoming-voice modem

this will tell IOS to divert incoming voice calls to the internal
modems.

Next ensure that you have some of the physical lines assigned to a
GroupAsync interface.  Your physical lines should be enabled for
either dialin, dialout, or inout, depending on what you're trying to
do.  The physical line numbering for modems on a 3600 series router
depend on the slot they are installed in - check

http://www.cisco.com/warp/public/471/108.html

for how to work out the numbers.  For a 30 modem module in slot 2,
which you want to enable for dial-in and dial-out, configure

line 65 96
  modem inout

Beyond here, there's tons of further configuration depending on what
you want to do.  Check out the dial configuration guide (I know - you
already have and it beat you!) but beware that Cisco changed the guide
totally between versions 11.3, 12.0 and 12.1.  For my money, the 12.0
guide at

http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/12cgc...

is by far the most useful and should give you clear advice.  If you
have more specific problems, feel free to come back here.

Regards

 
 
 

ISDN PRI (E1) and analog calls

Post by Arnold Mazu » Wed, 04 Jul 2001 04:52:07


Tkanks for everyone.
It works.
Arnold.
 
 
 

1. Supporting analog modem calls with ISDN PRI

What solutions are available to support users calling with analog
modems into a site equiped with ISDN PRI ?

I know that USR Total Control and Ascend MAX 4000 are two
solutions but they are so expensive. I wonder if there is
not a more affordable solution, even if it is not as well
integrated as these two "boxes".

Your comments are greatly appreciated.

Thanks.

2. Mp3's recorded in wrong order?

3. H.E.L.P : cisco 3640 + E1 PRI + 30 Digital Modems for (Analog/Digital) Dialup

4. i need to text edit!

5. AS5300, Quad E1/PRI and unframed E1 ?

6. Can you run WIN-OS2 directly from the native DOS prompt?

7. Quad E1/PRI on AS5300 and unframed E1

8. SOFTWARE GIVEAWAY

9. Help with D/300SC-E1 on BT E1 PRI

10. AS5300 (E1-PRI <-->VOIP) -- Only out-bound calls working ?!?!

11. PRI E1 Controller Resets and Calls not re-establishing

12. 3620 With E1 Pri & Modem module drops calls

13. AS5300: outgoing voice calls on E1 PRI