desperate for help with 1602 boot problem

desperate for help with 1602 boot problem

Post by aimle.. » Thu, 03 May 2001 01:43:49



I have a remote 1602 that's giving me fits booting.  Both the serial (Frame
Relay) and the ethernet interrface are active/up at boot time but the router
refuses to boot from the flash instead boots from ROM.  The config register
is set to 1602 as per

AIM_COLORADO(boot)#show version
Cisco Internetwork Operating System Software
IOS (tm) 1600 Software (C1600-BOOT-R), Version 11.1(10)AA, EARLY DEPLOYMENT
RELE
ASE SOFTWARE (fc1)
Copyright (c) 1986-1997 by cisco Systems, Inc.
Compiled Tue 18-Mar-97 14:01 by ccai
Image text-base: 0x04018060, data-base: 0x02005000

ROM: System Bootstrap, Version 11.1(10)AA, EARLY DEPLOYMENT RELEASE SOFTWARE
(fc1)

AIM_COLORADO uptime is 7 minutes
System restarted by reload
System image file is "eprom:c1600-boot-r.111-10.AA", booted via ROM

cisco 1602 (68360) processor (revision C) with 1536K/512K bytes of memory.
Processor board ID 11256713
X.25 software, Version 2.0, NET2, BFE and GOSIP compliant.
1 Ethernet/IEEE 802.3 interface.
1 Serial network interface.
On-board Switched 56K Line Interface.
System/IO memory with parity disabled
8K bytes of non-volatile configuration memory.
4096K bytes of processor board PCMCIA flash (Read/Write)

Configuration register is 0x2102

When I look at the flash file system (show flash all) here's what I get:

PCMCIA flash directory:
File  Length   Name/status
        addr      fcksum  ccksum
  1   2226518  c1600-y-mz.120-12
        0x40      0xEDB   0xEDB
[2226584 bytes used, 1967720 available, 4194304 total]
4096K bytes of processor board PCMCIA flash (Read/Write)

   Chip    Bank    Code      Size      Name
    1      1       01D5      1024KB    AMD   29F080
    2      1       01D5      1024KB    AMD   29F080
    1      2       01D5      1024KB    AMD   29F080
    2      2       01D5      1024KB    AMD   29F080

finally here's the config that I'm trying to boot from the router:

AIM_COLORADO(boot)#show config
Using 735 out of 7506 bytes
!
version 11.1
no service udp-small-servers
no service tcp-small-servers
!
hostname AIM_COLORADO
!
boot system flash c1600-y-mz.120-12

!
!
interface Ethernet0
 ip address 10.0.99.100 255.255.255.0
 no ip route-cache
!
interface Serial0
 no ip address
 encapsulation frame-relay
 no ip route-cache
 service-module 56k clock source line
 service-module 56k network-type dds
!
interface Serial0.1 point-to-point
 description frame to girard
 ip address 10.10.10.42 255.255.255.252
 no ip route-cache
 frame-relay interface-dlci 100
!
!
line con 0
line vty 0 4
login
!
end

Any help is greatly appreciated since I've had this site down for two days
and counting.  TIA

Barry Lance

 
 
 

desperate for help with 1602 boot problem

Post by Birger Toedtman » Thu, 03 May 2001 07:13:48


Hi,


Quote:> I have a remote 1602 that's giving me fits booting.  Both the serial (Frame
> Relay) and the ethernet interrface are active/up at boot time but the router
> refuses to boot from the flash instead boots from ROM.  The config register
> is set to 1602 as per

No, it is set to 0x2102:

[...]

Quote:> 8K bytes of non-volatile configuration memory.
> 4096K bytes of processor board PCMCIA flash (Read/Write)

> Configuration register is 0x2102

[...]

Did you ever try to set it to 0x2101 (via "config 0x2101", and then
a "reload")? Your system sais it is still in "boot" mode which means
that it has not loaded the IOS:

[...]

Quote:

> AIM_COLORADO(boot)#show config

                                       ^^^^

But this you may already now. My guess: If no "config 0x2101" will
do, the system is not loading your IOS from flash due to a reading
or checksum problem. If available, try to erase the flash ("write
erase") and download a different IOS image from a TFTP server.

Note: The router will load the bootstrap image prior to the IOS itself.
If anything happens when the router is loading the IOS, it will stop
in "(boot)" mode and also report on  console (serial) port - you may
have to hook a small system to the serial in order to see the boot stage
in full length.

Can you provide any snippets of the boot stage?

Regards,

--
  Birger T?dtmann
  Handwerker fr elektronische Netzwerke und deren Dienste
  00 83 E2 57 EC 60 0B 1C  D3 18 AE 2A 40 55 81 22

 
 
 

desperate for help with 1602 boot problem

Post by Ron » Thu, 03 May 2001 07:41:35


Barry,

The software upgrade tool claims you do not have enough RAM to run
12.0(12) IP only.  So if this is an upgrade and it has never worked
since the upgrade you need to back out the 12.0 and replace it with
something smaller or upgrade the RAM.

The selected Platform, Release, Software Features
Platform Release Software Features
1601R-1605R  12.0.12  IP  

Minimum Recommended Memory to download image - 4 MB Flash and 8 MB RAM

The mz in the file name seems to indicate you have a 1602R which uses
the compressed flash image then unpacks it and runs it in RAM and you
don't have enough RAM to unpack it so it has to run the ROM.

Ron


> I have a remote 1602 that's giving me fits booting.  Both the serial (Frame
> Relay) and the ethernet interrface are active/up at boot time but the router
> refuses to boot from the flash instead boots from ROM.  The config register
> is set to 1602 as per

> AIM_COLORADO(boot)#show version
> Cisco Internetwork Operating System Software
> IOS (tm) 1600 Software (C1600-BOOT-R), Version 11.1(10)AA, EARLY DEPLOYMENT
> RELE
> ASE SOFTWARE (fc1)
> Copyright (c) 1986-1997 by cisco Systems, Inc.
> Compiled Tue 18-Mar-97 14:01 by ccai
> Image text-base: 0x04018060, data-base: 0x02005000

> ROM: System Bootstrap, Version 11.1(10)AA, EARLY DEPLOYMENT RELEASE SOFTWARE
> (fc1)

> AIM_COLORADO uptime is 7 minutes
> System restarted by reload
> System image file is "eprom:c1600-boot-r.111-10.AA", booted via ROM

> cisco 1602 (68360) processor (revision C) with 1536K/512K bytes of memory.
> Processor board ID 11256713
> X.25 software, Version 2.0, NET2, BFE and GOSIP compliant.
> 1 Ethernet/IEEE 802.3 interface.
> 1 Serial network interface.
> On-board Switched 56K Line Interface.
> System/IO memory with parity disabled
> 8K bytes of non-volatile configuration memory.
> 4096K bytes of processor board PCMCIA flash (Read/Write)

> Configuration register is 0x2102

> When I look at the flash file system (show flash all) here's what I get:

> PCMCIA flash directory:
> File  Length   Name/status
>         addr      fcksum  ccksum
>   1   2226518  c1600-y-mz.120-12
>         0x40      0xEDB   0xEDB
> [2226584 bytes used, 1967720 available, 4194304 total]
> 4096K bytes of processor board PCMCIA flash (Read/Write)

>    Chip    Bank    Code      Size      Name
>     1      1       01D5      1024KB    AMD   29F080
>     2      1       01D5      1024KB    AMD   29F080
>     1      2       01D5      1024KB    AMD   29F080
>     2      2       01D5      1024KB    AMD   29F080

> finally here's the config that I'm trying to boot from the router:

> AIM_COLORADO(boot)#show config
> Using 735 out of 7506 bytes
> !
> version 11.1
> no service udp-small-servers
> no service tcp-small-servers
> !
> hostname AIM_COLORADO
> !
> boot system flash c1600-y-mz.120-12

> !
> !
> interface Ethernet0
>  ip address 10.0.99.100 255.255.255.0
>  no ip route-cache
> !
> interface Serial0
>  no ip address
>  encapsulation frame-relay
>  no ip route-cache
>  service-module 56k clock source line
>  service-module 56k network-type dds
> !
> interface Serial0.1 point-to-point
>  description frame to girard
>  ip address 10.10.10.42 255.255.255.252
>  no ip route-cache
>  frame-relay interface-dlci 100
> !
> !
> line con 0
> line vty 0 4
> login
> !
> end

> Any help is greatly appreciated since I've had this site down for two days
> and counting.  TIA

> Barry Lance

 
 
 

desperate for help with 1602 boot problem

Post by aimle.. » Thu, 03 May 2001 11:06:39


Yes, I know on the RAM requirement for the 12.0.12 release.  It was more of
a stop gap than anything since the router is 1400 miles from me and it's
nearly impossible to get these people to figure out how to hook a phone line
to the modem on my console port so I can get in that way.  I had a similiar
experience on another unit just like this one last week and had these cards
laying around from a couple 1605's I ordered and was able to use them as a
stop gap to get the people back up and running while I prepared another card
with IOS 11 for them .  It seemed to work in a pinch for them so I tried it
again.  The origional flash had a checksum error so......  The long and
short of it is that these people have some very poor power at the location
and this problem follows the latest of power outage/brownout/spike problems.
 I wish it were only at this location, but the workers tell me they
experience the same problems at their homes as well.  I was thinking it
might be wise to put the router on a UPS, but I've heard that can cause
problems too if a cell in the UPS starts to go bad.    I decided this
afternoon that I had to bite the bullet and order another unit for delivery
in the morning and will drop the config on it when it arrives.  One I get
the old unit back I'll look more into the boot process and erase and rewrite
the the flash.  Works out well if the unit is salvageable, since I usually
keep a spare unit on hand for these types of  situations.  I just had 2 go
bad over the last week before I could get another spare on hand.  Thanks
though for the response.

Barry Lance

 
 
 

desperate for help with 1602 boot problem

Post by Ron » Thu, 03 May 2001 22:52:32



> Yes, I know on the RAM requirement for the 12.0.12 release.  It was more of
> a stop gap than anything since the router is 1400 miles from me and it's
> nearly impossible to get these people to figure out how to hook a phone line
> to the modem on my console port so I can get in that way.  I had a similiar
> experience on another unit just like this one last week and had these cards
> laying around from a couple 1605's I ordered and was able to use them as a
> stop gap to get the people back up and running while I prepared another card
> with IOS 11 for them .  It seemed to work in a pinch for them so I tried it
> again.  The origional flash had a checksum error so......  The long and
> short of it is that these people have some very poor power at the location
> and this problem follows the latest of power outage/brownout/spike problems.
>  I wish it were only at this location, but the workers tell me they
> experience the same problems at their homes as well.  I was thinking it
> might be wise to put the router on a UPS, but I've heard that can cause
> problems too if a cell in the UPS starts to go bad.    I decided this
> afternoon that I had to bite the bullet and order another unit for delivery
> in the morning and will drop the config on it when it arrives.  One I get
> the old unit back I'll look more into the boot process and erase and rewrite
> the the flash.  Works out well if the unit is salvageable, since I usually
> keep a spare unit on hand for these types of  situations.  I just had 2 go
> bad over the last week before I could get another spare on hand.  Thanks
> though for the response.

> Barry Lance

I expect the other router may have had a bit more memory which is why it
worked and this one doesn't.

Get an APC UPS with the ethernet card in it.  Black Box carries them.
Then you plug the card into the local network and set the APC to send
syslog messages back to a syslog server (any UNIX/Linux box or you can
use an NT with Kiwi syslog daemon service manager) and it will tell you
when it starts feeling sick so you will have some warning.  We just
installed them in each of our equipment rooms.  Really work well.  If
money is too tight just get any UPS.  Certainly better than running bare
and most of them protect the router from * spikes.  We took a
lightning hit last summer and lost three older style UPSs but no
equipment was damaged.

Ron

 
 
 

1. 1602 booting into Rom Monitor

**** Post for FREE via your newsreader at post.usenet.com ****

I have a few Cisco 1602's that keep booting into Rom Monitor.  This happens
at times when the outlying offices test power to the building or an out
right power failure.  The register hasn't changed at all but I've seen this
problem on a few of our 1600's.  Anyone know or have an answer why?  Our
customers call and we have them power it off and back on...sometimes taking
4 reboots to finally work.  These are relatively new devices too....

===================
Cisco Internetwork Operating System Software
IOS (tm) 1600 Software (C1600-Y-M), Version 12.0(17), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2001 by cisco Systems, Inc.
Compiled Mon 16-Apr-01 16:56 by nmasa
Image text-base: 0x02005000, data-base: 0x0245FEDC

ROM: System Bootstrap, Version 12.0(3)T, RELEASE SOFTWARE (fc1)
ROM: 1600 Software (C1600-RBOOT-R), Version 12.0(3)T,  RELEASE SOFTWARE
(fc1)

xxxxxx uptime is 2 hours, 41 minutes
System restarted by power-on
System image file is "flash:c1600-y-mz.120-17"

cisco 1602 (68360) processor (revision C) with 6144K/2048K bytes of memory.
Processor board ID 26760340, with hardware revision 00000006
Bridging software.
X.25 software, Version 3.0.0.
1 Ethernet/IEEE 802.3 interface(s)
1 Serial network interface(s)
On-board Switched 56K Line Interface.
System/IO memory with parity disabled
8192K bytes of DRAM onboard
System running from RAM
7K bytes of non-volatile configuration memory.
4096K bytes of processor board PCMCIA flash (Read/Write)

Configuration register is 0x2102
==============================

TIA,
Jimmy

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
 *** Usenet.com - The #1 Usenet Newsgroup Service on The Planet! ***
                      http://www.usenet.com
Unlimited Download - 19 Seperate Servers - 90,000 groups - Uncensored
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

2. Old MSDN Univ Sub (2000) License Transfer

3. 1602 Boot Error IP FW Plus IPSEC 56 Feature Pack

4. how to do 64 bit literals in GNU/VC++? possible even????

5. Cisco 1602 Boot Errors

6. ZoneAlarm BLocking Video Sent out VIa Paltalk

7. 1602 Config Problem

8. Does Basic stores floats differently than C?

9. help needed with static NAT (1602, IOS 12.0)

10. 1602 router csu config problem

11. Cisco 1602 routing problem

12. help with 1602

13. 1602 RIP HELP!!!!