Accessing DHCP on remote subnet

Accessing DHCP on remote subnet

Post by Ray Brow » Mon, 10 Sep 2001 07:13:06



Hi,

I have a Frame-Relay circuit between Atlanta and Chicago.  I have a DHCP
server on the Chicago network.  In order for the client PC's in Atlanta to
get their IP information from the DHCP server in Chicago will I only need to
use the IP Helper-Address command on the router in Atlanta ?

Thanks,

Ray

sh run
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Chicago
!
memory-size iomem 25
ip subnet-zero
!
interface Serial0
 no ip address
 encapsulation frame-relay IETF
 frame-relay lmi-type ansi
!
interface Serial0.1 point-to-point
 description Connected to Atlanta
 ip address 172.16.0.1 255.255.255.0
 no arp frame-relay
 frame-relay interface-dlci 16
!
interface FastEthernet0
 ip address 10.255.255.1 255.0.0.0
 speed auto
 half-duplex
!
ip classless
no ip http server
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
no scheduler allocate
end

XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

sh run
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Atlanta
!
memory-size iomem 25
ip subnet-zero
!
interface Serial0
 no ip address
 encapsulation frame-relay IETF
 frame-relay lmi-type ansi
!
interface Serial0.1 point-to-point
 description Connected to Chicago
 ip address 172.16.0.2 255.255.255.0
 no arp frame-relay
 frame-relay interface-dlci 16
!
interface FastEthernet0
 ip address 10.255.255.2 255.0.0.0
 speed auto
 half-duplex
!
ip classless
no ip http server
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

 
 
 

Accessing DHCP on remote subnet

Post by Christopher A. Jaros » Mon, 10 Sep 2001 13:01:10


yup

chrisj


> Hi,

> I have a Frame-Relay circuit between Atlanta and Chicago.  I have a DHCP
> server on the Chicago network.  In order for the client PC's in Atlanta to
> get their IP information from the DHCP server in Chicago will I only need to
> use the IP Helper-Address command on the router in Atlanta ?

> Thanks,

> Ray

> sh run
> Building configuration...

> Current configuration:
> !
> version 12.1
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname Chicago
> !
> memory-size iomem 25
> ip subnet-zero
> !
> interface Serial0
>  no ip address
>  encapsulation frame-relay IETF
>  frame-relay lmi-type ansi
> !
> interface Serial0.1 point-to-point
>  description Connected to Atlanta
>  ip address 172.16.0.1 255.255.255.0
>  no arp frame-relay
>  frame-relay interface-dlci 16
> !
> interface FastEthernet0
>  ip address 10.255.255.1 255.0.0.0
>  speed auto
>  half-duplex
> !
> ip classless
> no ip http server
> !
> dialer-list 1 protocol ip permit
> dialer-list 1 protocol ipx permit
> !
> line con 0
>  transport input none
> line aux 0
> line vty 0 4
>  login
> !
> no scheduler allocate
> end

> XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

> sh run
> Building configuration...

> Current configuration:
> !
> version 12.1
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname Atlanta
> !
> memory-size iomem 25
> ip subnet-zero
> !
> interface Serial0
>  no ip address
>  encapsulation frame-relay IETF
>  frame-relay lmi-type ansi
> !
> interface Serial0.1 point-to-point
>  description Connected to Chicago
>  ip address 172.16.0.2 255.255.255.0
>  no arp frame-relay
>  frame-relay interface-dlci 16
> !
> interface FastEthernet0
>  ip address 10.255.255.2 255.0.0.0
>  speed auto
>  half-duplex
> !
> ip classless
> no ip http server
> !
> dialer-list 1 protocol ip permit
> dialer-list 1 protocol ipx permit
> !
> line con 0
>  transport input none
> line aux 0
> line vty 0 4
>  login
> !
> end


 
 
 

Accessing DHCP on remote subnet

Post by albert.b.. » Tue, 11 Sep 2001 18:05:58


a helpful enhancement:

ip dhcp-server 172.16.249.2
ip dhcp-server 172.16.249.3
!
!
interface Vlan10
 ip address 172.16.10.252 255.255.255.0
 ip helper-address 172.16.249.2
 ip helper-address 172.16.249.3

Albert

 
 
 

1. DHCP Relay with same IP subnet on remote network

Hi,

I have researched most of Cisco's site and Googled everywhere but I
can't find an example of what I need to do, I hope someone can give me
a hint.

I have a local network with a DHCP server and some clients, and a
remote network (communicated via the Internet) with some clients only.

On top of securing the link (I am setting up a VPN) I need those remote
clients to communicate with my local DHCP server, picking up the same
IP addresses they would be getting locally. This means the local and
remote networks should act as a single flat LAN within the same logical
IP subnet.

Right now it is working via a set of Linux-based "tunnel servers" (one
of each end) that I need to retire, but I cannot find how to configure
this on my Cisco routers.

Is it feasible at all?

Thanks,
Javier

--
Javier
------------------------------------------------------------------------
Posted via http://www.mcse.ms
------------------------------------------------------------------------
View this thread: http://www.mcse.ms/message658571.html

2. D3D or OpenGL

3. Internet access on remote subnet

4. Need Kerberos for OpenVMS!

5. Problem With DHCP (former 1 DHCP server for different subnets )

6. DrawString in panels supported?

7. Problem With DHCP (former 1 DHCP server for different subnets

8. repost: Beta testers reqd

9. Problem With DHCP (former 1 DHCP server for different subnets)

10. execution of remote programs with remote hardware access

11. @Home Remote News Servers slowing Remote Access

12. @Home Remote News Servers slowing Remote Access-bastards