VLAN port with internet access can access only one vlan?

VLAN port with internet access can access only one vlan?

Post by gooderthan.. » Sun, 23 Apr 2006 04:38:26



I've been searching around for a while and have come up with more
questions than answers

I have two cisco switches (2950 and 3500) which are connected to
eachother with a vlan 1 (default) and vlan 22.

The vlan aspect is working fine as it should be, each switch is
basically divied in half w/ half the ports on vlan 22 and half on vlan
1.  I have them trunked together and that works fine.

Now on one switch I have my internet connection on a port.

If I set the port to access mode and put in vlan 22 then vlan 22 has an
internet connection
If I put in vlan 1 then vlan 1 has the internet connection

It will not let me put in vlan 1 & 22 at the same time!
I have seen things such as ip-helper, which I don't think is a problem,
apparently each machine is getting an ip address from the dhcp server
(the router).

Also I'm confused to as why a VLAN would have an IP address at all...
what is the purpose?  An example please?  =)

Here's the configuration file with the switch with internet connection
port:

ip subnet-zero
no ip domain-lookup
ip dhcp-server 192.168.2.1
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
interface FastEthernet0/1
 no ip address
 no cdp enable
!
interface FastEthernet0/2
 switchport access vlan 22
 no ip address
 no cdp enable
!
interface FastEthernet0/3
 no ip address
 no cdp enable
!
interface FastEthernet0/4
 no ip address
 no cdp enable
!
interface FastEthernet0/5
 no ip address
 no cdp enable
!
interface FastEthernet0/6
 no ip address
 no cdp enable
!
interface FastEthernet0/7
 no ip address
 no cdp enable
!
interface FastEthernet0/8
 no ip address
 no cdp enable
!
interface FastEthernet0/9
 no ip address
 no cdp enable
!
interface FastEthernet0/10
 no ip address
 no cdp enable
!
interface FastEthernet0/11
 switchport access vlan 22
 switchport mode trunk
no ip address
 speed 100
 no cdp enable
!
interface FastEthernet0/12   --- Internet Connection in this port
 switchport mode access
 no ip address
 no cdp enable
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Vlan22
 ip address 192.168.2.3 255.255.255.0
 no ip route-cache
!
ip http server
!
no cdp run
!
line con 0
!
end

 
 
 

VLAN port with internet access can access only one vlan?

Post by Mark William » Sun, 23 Apr 2006 04:52:22


In order to forward traffic between VLANs, you need something to
perfrom routing. The 3500 is a multilayer switch, right? You will need
to configure vlan interfaces and routing on the 3500 to support
communication between vlans 1 and 22.

You may also need some form of NAT as well.

 
 
 

VLAN port with internet access can access only one vlan?

Post by java32 » Mon, 24 Apr 2006 09:23:04


You need a L3 device to router traffic from both vlan 1 and vlan 22. Here
are some suggestions:
1)  connect vlan 1 and 22 to different ports on the router (e.g. vlan 1 <->
fa0/0 and vlan 22 <-> fa0/1)
2)create a trunk port between router and the switch (define fastethernet
subinterfaces)
3) create layer 3 interfaces for vlan1 and 22 on the switch.

Good luck

 
 
 

1. machines in VLAN not able to access internet

I just recently purchased a cisco 1841 router.  I have a DSL line with
static IP address.  I setup eth1 to connect to the DSL modem and eth0
is setup with IP 10.10.10.1 (factory default).  I also configured VLAN1
to handle 192.168.1.1/24.

When I test, I can get 2 machines within VLAN1 to see ping each other
and they can also ping the static IP, 192.168.1.1.  But, non of them
are able to connect to the internet.  Am I missing something here?
Maybe a static route?  but static route from where to where?  Can
someone help?

Thanks in advance.
Steve_sc33

2. DOS4GW and Mode X

3. vlan internet access problem

4. Atari 520ST w/4 Megs Mono Monitor 1.4 TOS 720K DSDD

5. Changing from one VLAN to multiple VLANs

6. Does SBS have a modemshare client for Win2000 ????

7. VLAN Trunking Cisco Cat 5500 switch (multiple vlans per port) help please

8. Lib

9. How to move a port from one vlan to another?

10. One port belongs several vlans?

11. How to put multiple ports into one vlan with single command.

12. vlans, one router port, can it be done?

13. restricting access on a VLAN