2 C803 Routers, 1 in the Netherlands, 1 in China

2 C803 Routers, 1 in the Netherlands, 1 in China

Post by Ferry Slotboo » Thu, 22 Jun 2000 04:00:00



I have a problem with two Cisco 803 Routers. One of them is
located in the Netherlands, and the other one is located in
China. The two routers need to build a connection by ISDN with
PPP encapsulation. It sounds pretty basic, but I can`t get it to
work. Does anybody know whether there needs to be configured
some additional parameters for communication over ISDN with
China.
Both routers have 1207T software.
I have attached the configs of both routers. They are basic
configurations that work fine in the Netherlands.
Any suggestions would be welcome.

CONFIG HOLLAND
Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname NL-AMV-ISDN
!
boot buffersize 8061
boot system flash c800-y6-mw.1207T
enable secret xxxxxx
!
!
!
!
!
ip subnet-zero
!
no ip domain-lookup
isdn switch-type basic-net3
isdn voice-call-failure 0
isdn tei-negotiation first-call
!
!
!
interface Ethernet0
 ip address 10.16.123.9 255.255.255.0
 no ip directed-broadcast
 no keepalive
!
interface BRI0
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 dialer rotary-group 1
 isdn switch-type basic-net3
!
interface Dialer1
 bandwidth 64
 ip address 10.31.206.1 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 no ip split-horizon
 dialer in-band
 dialer map ip 10.31.206.10 name NL-CHI-ISDN 00861065612764
 dialer-group 1
!
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 10.31.206.10
!
dialer-list 1 protocol ip permit
!
line con 0
 transport input none
 line vty 0 4
 password xxxxxx
 login
!
end

CONFIG CHINA
Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname NL-CHI-ISDN
!
enable secret xxxxxx
!
!
ip subnet-zero
!
no ip domain-lookup
isdn switch-type basic-net3
isdn tei-negotiation first-call
!
!
!
interface Ethernet0
 ip address 10.160.123.254 255.255.192.0
 no ip directed-broadcast
 no keepalive
 no shutdown
!
interface BRI0
 bandwidth 64
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 dialer rotary-group 1
 isdn switch-type basic-net3
 no cdp enable
!
interface Dialer1
 bandwidth 64
 ip address 10.31.206.10 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 no ip split-horizon
 dialer in-band
 dialer map ip 10.31.206.1 name NL-AMV-ISDN 0031204416853
 dialer-group 1
 no cdp enable
!
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 10.31.206.1
!
dialer-list 1 protocol ip permit
!
line con 0
 transport input none
 line vty 0 4
 password xxxxxx
 login
!
end

Got questions?  Get answers over the phone at Keen.com.
Up to 100 minutes free!
http://www.keen.com

 
 
 

2 C803 Routers, 1 in the Netherlands, 1 in China

Post by Dirk » Fri, 23 Jun 2000 04:00:00


Hi Ferry,

The problem is in the config of your China router. Here you also use ISDN
SWITCH-TYPE BASIC-NET3, which is the type specifically for European ISDN
switches.
You need to change this both in config mode as in interface (bri) mode. I'm
not sure which switch-type you should use in China, but easiest is to
contact your provider of the ISDN line. They can tell you this.
On CCO they don't mention China for the switchtypes.

Table  12: ISDN Service Provider Switch Types
Keywords by Area      Switch Type
none                    No switch defined
Australia
basic-ts013        Australian TS013 switches
Europe
basic-1tr6           German 1TR6 ISDN switches
basic-nwnet3      Norway NET3 switches (phase 1)
basic-net3          NET3 ISDN switches; covers the Euro-ISDN E-DSS1
signaling system and is ETSI-compliant.
vn2                      French VN2 ISDN BRI switches
vn3                      French VN3 ISDN BRI switches
vn4                      French VN4 ISDN BRI switches
Japan
ntt                        Japanese NTT ISDN switches
North America
basic-5ess         AT&T basic rate switches
basic-dms100   NT DMS-100 basic rate switches
basic-ni1            National ISDN-1 switches
New Zealand
basic-nznet3     New Zealand Net3 switches

Hope this helps,
Dirk


Quote:>I have a problem with two Cisco 803 Routers. One of them is
>located in the Netherlands, and the other one is located in
>China. The two routers need to build a connection by ISDN with
>PPP encapsulation. It sounds pretty basic, but I can`t get it to
>work. Does anybody know whether there needs to be configured
>some additional parameters for communication over ISDN with
>China.
>Both routers have 1207T software.
>I have attached the configs of both routers. They are basic
>configurations that work fine in the Netherlands.
>Any suggestions would be welcome.

>CONFIG HOLLAND
>Current configuration:
>!
>version 12.0
>no service pad
>service timestamps debug uptime
>service timestamps log uptime
>no service password-encryption
>!
>hostname NL-AMV-ISDN
>!
>boot buffersize 8061
>boot system flash c800-y6-mw.1207T
>enable secret xxxxxx
>!
>!
>!
>!
>!
>ip subnet-zero
>!
>no ip domain-lookup
>isdn switch-type basic-net3
>isdn voice-call-failure 0
>isdn tei-negotiation first-call
>!
>!
>!
>interface Ethernet0
> ip address 10.16.123.9 255.255.255.0
> no ip directed-broadcast
> no keepalive
>!
>interface BRI0
> no ip address
> no ip directed-broadcast
> encapsulation ppp
> dialer rotary-group 1
> isdn switch-type basic-net3
>!
>interface Dialer1
> bandwidth 64
> ip address 10.31.206.1 255.255.255.0
> no ip directed-broadcast
> encapsulation ppp
> no ip split-horizon
> dialer in-band
> dialer map ip 10.31.206.10 name NL-CHI-ISDN 00861065612764
> dialer-group 1
>!
>no ip http server
>ip classless
>ip route 0.0.0.0 0.0.0.0 10.31.206.10
>!
>dialer-list 1 protocol ip permit
>!
>line con 0
> transport input none
> line vty 0 4
> password xxxxxx
> login
>!
>end

>CONFIG CHINA
>Current configuration:
>!
>version 12.0
>no service pad
>service timestamps debug uptime
>service timestamps log uptime
>no service password-encryption
>!
>hostname NL-CHI-ISDN
>!
>enable secret xxxxxx
>!
>!
>ip subnet-zero
>!
>no ip domain-lookup
>isdn switch-type basic-net3
>isdn tei-negotiation first-call
>!
>!
>!
>interface Ethernet0
> ip address 10.160.123.254 255.255.192.0
> no ip directed-broadcast
> no keepalive
> no shutdown
>!
>interface BRI0
> bandwidth 64
> no ip address
> no ip directed-broadcast
> encapsulation ppp
> dialer rotary-group 1
> isdn switch-type basic-net3
> no cdp enable
>!
>interface Dialer1
> bandwidth 64
> ip address 10.31.206.10 255.255.255.0
> no ip directed-broadcast
> encapsulation ppp
> no ip split-horizon
> dialer in-band
> dialer map ip 10.31.206.1 name NL-AMV-ISDN 0031204416853
> dialer-group 1
> no cdp enable
>!
>no ip http server
>ip classless
>ip route 0.0.0.0 0.0.0.0 10.31.206.1
>!
>dialer-list 1 protocol ip permit
>!
>line con 0
> transport input none
> line vty 0 4
> password xxxxxx
> login
>!
>end

>Got questions?  Get answers over the phone at Keen.com.
>Up to 100 minutes free!
>http://www.keen.com


 
 
 

2 C803 Routers, 1 in the Netherlands, 1 in China

Post by Harr » Fri, 23 Jun 2000 04:00:00


Try the line "isdn send-alerting" under the bri interface


Quote:> I have a problem with two Cisco 803 Routers. One of them is
> located in the Netherlands, and the other one is located in
> China. The two routers need to build a connection by ISDN with
> PPP encapsulation. It sounds pretty basic, but I can`t get it to
> work. Does anybody know whether there needs to be configured
> some additional parameters for communication over ISDN with
> China.
> Both routers have 1207T software.
> I have attached the configs of both routers. They are basic
> configurations that work fine in the Netherlands.
> Any suggestions would be welcome.

> CONFIG HOLLAND
> Current configuration:
> !
> version 12.0
> no service pad
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname NL-AMV-ISDN
> !
> boot buffersize 8061
> boot system flash c800-y6-mw.1207T
> enable secret xxxxxx
> !
> !
> !
> !
> !
> ip subnet-zero
> !
> no ip domain-lookup
> isdn switch-type basic-net3
> isdn voice-call-failure 0
> isdn tei-negotiation first-call
> !
> !
> !
> interface Ethernet0
>  ip address 10.16.123.9 255.255.255.0
>  no ip directed-broadcast
>  no keepalive
> !
> interface BRI0
>  no ip address
>  no ip directed-broadcast
>  encapsulation ppp
>  dialer rotary-group 1
>  isdn switch-type basic-net3
> !
> interface Dialer1
>  bandwidth 64
>  ip address 10.31.206.1 255.255.255.0
>  no ip directed-broadcast
>  encapsulation ppp
>  no ip split-horizon
>  dialer in-band
>  dialer map ip 10.31.206.10 name NL-CHI-ISDN 00861065612764
>  dialer-group 1
> !
> no ip http server
> ip classless
> ip route 0.0.0.0 0.0.0.0 10.31.206.10
> !
> dialer-list 1 protocol ip permit
> !
> line con 0
>  transport input none
>  line vty 0 4
>  password xxxxxx
>  login
> !
> end

> CONFIG CHINA
> Current configuration:
> !
> version 12.0
> no service pad
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname NL-CHI-ISDN
> !
> enable secret xxxxxx
> !
> !
> ip subnet-zero
> !
> no ip domain-lookup
> isdn switch-type basic-net3
> isdn tei-negotiation first-call
> !
> !
> !
> interface Ethernet0
>  ip address 10.160.123.254 255.255.192.0
>  no ip directed-broadcast
>  no keepalive
>  no shutdown
> !
> interface BRI0
>  bandwidth 64
>  no ip address
>  no ip directed-broadcast
>  encapsulation ppp
>  dialer rotary-group 1
>  isdn switch-type basic-net3
>  no cdp enable
> !
> interface Dialer1
>  bandwidth 64
>  ip address 10.31.206.10 255.255.255.0
>  no ip directed-broadcast
>  encapsulation ppp
>  no ip split-horizon
>  dialer in-band
>  dialer map ip 10.31.206.1 name NL-AMV-ISDN 0031204416853
>  dialer-group 1
>  no cdp enable
> !
> no ip http server
> ip classless
> ip route 0.0.0.0 0.0.0.0 10.31.206.1
> !
> dialer-list 1 protocol ip permit
> !
> line con 0
>  transport input none
>  line vty 0 4
>  password xxxxxx
>  login
> !
> end

> Got questions?  Get answers over the phone at Keen.com.
> Up to 100 minutes free!
> http://www.keen.com