%THISDIRNAME%

%THISDIRNAME%

Post by Henk Devo » Thu, 12 Jun 2003 16:47:09



I'm writing a rooted namespace extension using tyhe def view and the
standard web view.
In the web view, where the folder name normally is, i get %THISDIRNAME%
instead.
I remember having had this before, and then it was magically fixed, but i
don't remember how.
Any ideas?
I'm testing on Windows 2000.

--
Henk Devos
www.whirlingdervishes.com

 
 
 

%THISDIRNAME%

Post by mike » Thu, 12 Jun 2003 23:04:47



Quote:> I'm writing a rooted namespace extension using tyhe def view and the
> standard web view.
> In the web view, where the folder name normally is, i get %THISDIRNAME%
> instead.
> I remember having had this before, and then it was magically fixed, but i
> don't remember how.
> Any ideas?
> I'm testing on Windows 2000.

MSDN Oct 2001 Technical Articles
"A Brand New Web Look for Your Folders", Dino Esposito, May 1999

 
 
 

%THISDIRNAME%

Post by Henk Devo » Fri, 13 Jun 2003 04:09:44


This doesn't help me.
To make things more clear:
My NSE is completely functional.
So is the web view.
In the root folder everything is fine.
In the subfolders i get %THISDIRNAME% instead of the folder name, i.e. for
some reason this variable is not being expanded.
There must be something i'm not doing right, or something i forgot to
implement?



says...
> > I'm writing a rooted namespace extension using tyhe def view and the
> > standard web view.
> > In the web view, where the folder name normally is, i get %THISDIRNAME%
> > instead.
> > I remember having had this before, and then it was magically fixed, but
i
> > don't remember how.
> > Any ideas?
> > I'm testing on Windows 2000.

> MSDN Oct 2001 Technical Articles
> "A Brand New Web Look for Your Folders", Dino Esposito, May 1999

 
 
 

%THISDIRNAME%

Post by Henk Devo » Fri, 13 Jun 2003 08:07:07


What i do is this:
I'm browsing the contents of a file with the command line explorer
/n,/e,/root,{clsid},"%1".
The file is not otherwise associated with the class id.
This seems to work fine for the most part, except for the %THISDIRNAME% and
some other details. When i do make the normal association everything works
fine.
Is this a bug?



says...
> > I'm writing a rooted namespace extension using tyhe def view and the
> > standard web view.
> > In the web view, where the folder name normally is, i get %THISDIRNAME%
> > instead.
> > I remember having had this before, and then it was magically fixed, but
i
> > don't remember how.
> > Any ideas?
> > I'm testing on Windows 2000.

> MSDN Oct 2001 Technical Articles
> "A Brand New Web Look for Your Folders", Dino Esposito, May 1999

 
 
 

1. %THISDIRNAME% is shown in my explorer

Do not post binaries to non-binary accepting newsgroups - like this one.

2. Windows SDK for Pilot

3. %THISDIRNAME% showing up in folders

4. DLL hell