CW 7 printing errors

CW 7 printing errors

Post by Stephen S. Ashl » Tue, 02 Apr 2002 03:17:03



In the IDE editor my lines are lined up correctly on the desired tab
stop, but when I print, three of the lines line up one tab stop to the
left.

Also, I select "use syntax highlighting," but everything gets printed
in black and white, even though the printer properties are set for
color printing.

Does anyone know how to fix these problems?

--SSA

 
 
 

CW 7 printing errors

Post by Ben Combe » Tue, 02 Apr 2002 06:32:24




Quote:> In the IDE editor my lines are lined up correctly on the desired tab
> stop, but when I print, three of the lines line up one tab stop to the
> left.

> Also, I select "use syntax highlighting," but everything gets printed
> in black and white, even though the printer properties are set for
> color printing.

> Does anyone know how to fix these problems?

If you have some mechanism for printing in PostScript, that usually
works to clear up the problems.  Setting up a dummy PS printer, printing
to a file, then rendering it out using GhostScript might work.

Unfortunately, there are some bad Windows printing problems in the 4.1
IDE used in CW Palm V7.  Some of them were fixed for 4.2.5 as used in CW
Palm V8, and a few more will be fixed in the 8.2 patch to be released
soon.  In house, very few of the developers print on a regular basis,
and after that, all of the printers are PostScript (since they work
better with the Macintosh) and we don't get a lot of testing on low-end
devices and therefore missed some real bad bugs.

--

CodeWarrior for Palm OS technical lead