CodeWarrior for Palm 8.3 Patch Available.

CodeWarrior for Palm 8.3 Patch Available.

Post by MW Ro » Wed, 31 Jul 2002 06:09:24



CodeWarrior Development Tools for Palm OS Platform, Version 8.3?

This update is for CodeWarrior Development Tools for Palm OS Platform
versions 8.0 - 8.2, Professional and Enterprise Macintosh and Windows
hosted editions. All fixes in the previous updates are included, so you
do not need to download those files. This update addresses several
issues reported by users in the runtime libraries, MSL for Palm OS, and
Linker. In addition, the Palm OS wizards can now detect if you are using
Palm OS 4 or 5 SDK and reconfigure so you are using the proper templates
for resources.

It is highly recommended that you read the release notes before
installing the update.

--
           CodeWarrior Learning Edition v3
   Professional C/C++ and JavaTM programming made easy!
     http://www.metrowerks.com/desktop/learning_ed

 Metrowerks, maker of CodeWarrior  -  "Software Starts Here"  

 
 
 

CodeWarrior for Palm 8.3 Patch Available.

Post by dla » Thu, 01 Aug 2002 15:03:08



7/29/02 2:09 PM:

Quote:

> CodeWarrior Development Tools for Palm OS Platform, Version 8.3?

> This update is for CodeWarrior Development Tools for Palm OS Platform
> versions 8.0 - 8.2, Professional and Enterprise Macintosh and Windows
> hosted editions. All fixes in the previous updates are included, so you
> do not need to download those files. This update addresses several
> issues reported by users in the runtime libraries, MSL for Palm OS, and
> Linker. In addition, the Palm OS wizards can now detect if you are using
> Palm OS 4 or 5 SDK and reconfigure so you are using the proper templates
> for resources.

> It is highly recommended that you read the release notes before
> installing the update.

So, I installed and now I the IDE won't launch. I installed over 7.0 Mac OS
merge w/ Palm 8.0. I get error of something like this: "MacOSXUtils.bundle
is missing or old."

What did I do wrong?

iBook 500, OS X 10.1.5 CW 7.0+PALM OS 8

Also, I've been getting errors in with the PalmRez Post-Linker being
missing, but it is there in the plugins folder.

Any ideas? Should I re-install. This was all working fine on my G4 in OS
9.2.2 but I decided to move it to my laptop that I use most. Now, lots of
problems. I probably should have read those release notes first.

_____________________
David Austin

_____________________

 
 
 

CodeWarrior for Palm 8.3 Patch Available.

Post by Ben Combe » Thu, 01 Aug 2002 16:23:55


Quote:> So, I installed and now I the IDE won't launch. I installed over 7.0 Mac OS
> merge w/ Palm 8.0. I get error of something like this: "MacOSXUtils.bundle
> is missing or old."

We've heard of this problem before, and its usually solved by
reinstalling the patch.  This bundle is shipped as part of the IDE, and
for some reason I don't understand, it sometimes seems to go awry.

Quote:> What did I do wrong?

> iBook 500, OS X 10.1.5 CW 7.0+PALM OS 8

> Also, I've been getting errors in with the PalmRez Post-Linker being
> missing, but it is there in the plugins folder.

This is very odd... we didn't change the post-linker in this release.  
You should be using the postlinker from SDK 4.0 Update 1, and
reinstalling that update from palmos.com should fix this error.

Quote:> Any ideas? Should I re-install. This was all working fine on my G4 in OS
> 9.2.2 but I decided to move it to my laptop that I use most. Now, lots of
> problems. I probably should have read those release notes first.

I will try to recreate on my OS X box at work.  I know the various
components were working fine on my system, and the patch passed QA
testing, but perhaps something odd about 10.1.5 was missed, or maybe its
just an installer problem.
--

CodeWarrior for Palm OS technical lead
Get help at http://palmoswerks.com/
 
 
 

CodeWarrior for Palm 8.3 Patch Available.

Post by dla » Fri, 02 Aug 2002 11:46:49



on 7/31/02 12:23 AM:

Quote:>> So, I installed and now I the IDE won't launch. I installed over 7.0 Mac OS
>> merge w/ Palm 8.0. I get error of something like this: "MacOSXUtils.bundle
>> is missing or old."

> We've heard of this problem before, and its usually solved by
> reinstalling the patch.  This bundle is shipped as part of the IDE, and
> for some reason I don't understand, it sometimes seems to go awry.

I trid reinstalling the patch. Didn't work. I tried deleting the
CWMacOSXUtils bundle, then run the patch. Still, didn't work.

Quote:

>> What did I do wrong?

>> iBook 500, OS X 10.1.5 CW 7.0+PALM OS 8

>> Also, I've been getting errors in with the PalmRez Post-Linker being
>> missing, but it is there in the plugins folder.

> This is very odd... we didn't change the post-linker in this release.
> You should be using the postlinker from SDK 4.0 Update 1, and
> reinstalling that update from palmos.com should fix this error.

I was having this problem prior to the update patch. This is why I sought
out the patch. I thought maybe it would magically fix it. Now after the
patch, CW will not even launch. Therefore, can't get a post-linker error.

Quote:

>> Any ideas? Should I re-install. This was all working fine on my G4 in OS
>> 9.2.2 but I decided to move it to my laptop that I use most. Now, lots of
>> problems. I probably should have read those release notes first.

> I will try to recreate on my OS X box at work.  I know the various
> components were working fine on my system, and the patch passed QA
> testing, but perhaps something odd about 10.1.5 was missed, or maybe its
> just an installer problem.

Is there a mail address I should be properly addressing these issues outside
of this newsgroup?

_____________________
David Austin

_____________________

 
 
 

CodeWarrior for Palm 8.3 Patch Available.

Post by Ben Combe » Fri, 02 Aug 2002 16:12:47


Quote:> I trid reinstalling the patch. Didn't work. I tried deleting the
> CWMacOSXUtils bundle, then run the patch. Still, didn't work.


corrected version of this bundle file.  I talked with our support
department today about this problem, but we didn't have a solution other
than to manually send you the bundle -- it may be an installer issue --
you don't have the CW IDE running when you run the patch installer, do
you?

Quote:> Is there a mail address I should be properly addressing these issues outside
> of this newsgroup?


--

CodeWarrior for Palm OS technical lead
Get help at http://palmoswerks.com/

 
 
 

CodeWarrior for Palm 8.3 Patch Available.

Post by John Kelse » Fri, 02 Aug 2002 22:32:16


It there a reason my CodeWarrior Updater can't find the update?  I've
manually found it on the web site but doesn't that defeat the purpose of the
Updateer?

John


> CodeWarrior Development Tools for Palm OS Platform, Version 8.3

> This update is for CodeWarrior Development Tools for Palm OS Platform
> versions 8.0 - 8.2, Professional and Enterprise Macintosh and Windows
> hosted editions. All fixes in the previous updates are included, so you
> do not need to download those files. This update addresses several
> issues reported by users in the runtime libraries, MSL for Palm OS, and
> Linker. In addition, the Palm OS wizards can now detect if you are using
> Palm OS 4 or 5 SDK and reconfigure so you are using the proper templates
> for resources.

> It is highly recommended that you read the release notes before
> installing the update.

> --
>            CodeWarrior Learning Edition v3
>    Professional C/C++ and JavaTM programming made easy!
>      http://www.metrowerks.com/desktop/learning_ed

>  Metrowerks, maker of CodeWarrior  -  "Software Starts Here"


 
 
 

CodeWarrior for Palm 8.3 Patch Available.

Post by Ben Combe » Fri, 02 Aug 2002 23:18:24



says...

Quote:> It there a reason my CodeWarrior Updater can't find the update?  I've
> manually found it on the web site but doesn't that defeat the purpose of the
> Updateer?

When the web team reworked the Metrowerks web site in early July, moving
to a new content management system, they managed to break a lot of URLs
that had worked before, including the one that the Updater uses.  I
thought this had been fixed already -- I'll check with our installer
developer today.

Thanks for the report.
--

CodeWarrior for Palm OS technical lead
Get help at http://palmoswerks.com/

 
 
 

CodeWarrior for Palm 8.3 Patch Available.

Post by John Kelse » Tue, 06 Aug 2002 22:49:58


Ben,

Still isn't working.  I noticed that it appears to successfully get product
version information and then reports no update necessary.  Could it be that
something just needs to be updated on your web site?
John

> It there a reason my CodeWarrior Updater can't find the update?  I've
> manually found it on the web site but doesn't that defeat the purpose of
the
> Updateer?

> John



> > CodeWarrior Development Tools for Palm OS Platform, Version 8.3

> > This update is for CodeWarrior Development Tools for Palm OS Platform
> > versions 8.0 - 8.2, Professional and Enterprise Macintosh and Windows
> > hosted editions. All fixes in the previous updates are included, so you
> > do not need to download those files. This update addresses several
> > issues reported by users in the runtime libraries, MSL for Palm OS, and
> > Linker. In addition, the Palm OS wizards can now detect if you are using
> > Palm OS 4 or 5 SDK and reconfigure so you are using the proper templates
> > for resources.

> > It is highly recommended that you read the release notes before
> > installing the update.

> > --
> >            CodeWarrior Learning Edition v3
> >    Professional C/C++ and JavaTM programming made easy!
> >      http://www.metrowerks.com/desktop/learning_ed

> >  Metrowerks, maker of CodeWarrior  -  "Software Starts Here"