Using Palm SDK 3.5 with CW for Palm OS R6 (on the Mac)

Using Palm SDK 3.5 with CW for Palm OS R6 (on the Mac)

Post by v_i_n_.. » Sat, 21 Oct 2000 04:00:00



We're trying to use the 3.5 SDK with our CW for Palm OS R6 tools (Mac
version), but experiencing lots of crashes when trying to use the
de*. Has anybody out there done this successfully? Which version of
the Palm OS ROM did you use with the Palm Emulator? For that matter,
which version of the Palm Emulator did you use - the version that ships
with CW for Palm OS R6 is the Palm OS Emulator 2.1d29.

The Mac is running MacOS 9.0.4...

When first installed, CW for Palm OS R6 comes integrated with the Palm OS
3.1 SDK - and this configuration works fine. But we'd like to be able to
upgrade to the 3.5 SDK and keep using the Metrowerks IDE, if at all
possible.

Thanks!

Sent via Deja.com http://www.veryComputer.com/
Before you buy.

 
 
 

Using Palm SDK 3.5 with CW for Palm OS R6 (on the Mac)

Post by MWRo » Tue, 24 Oct 2000 04:00:00



>We're trying to use the 3.5 SDK with our CW for Palm OS R6 tools (Mac
>version), but experiencing lots of crashes when trying to use the
>de*. Has anybody out there done this successfully? Which version of
>the Palm OS ROM did you use with the Palm Emulator? For that matter,
>which version of the Palm Emulator did you use - the version that ships
>with CW for Palm OS R6 is the Palm OS Emulator 2.1d29.

>The Mac is running MacOS 9.0.4...

>When first installed, CW for Palm OS R6 comes integrated with the Palm OS
>3.1 SDK - and this configuration works fine. But we'd like to be able to
>upgrade to the 3.5 SDK and keep using the Metrowerks IDE, if at all
>possible.

Make sure you did all the updates correctly, maybe even uninstalling and
reinstalling them.  If this is all setup right and you are still having a

Ron

--
 "...we feel it's truly the best of the bunch."
Internet Week Reviews...Java Wars 2000
http://www.veryComputer.com/



 
 
 

Using Palm SDK 3.5 with CW for Palm OS R6 (on the Mac)

Post by MWRo » Wed, 25 Oct 2000 04:00:00



>We're trying to use the 3.5 SDK with our CW for Palm OS R6 tools (Mac
>version), but experiencing lots of crashes when trying to use the
>de*. Has anybody out there done this successfully? Which version of
>the Palm OS ROM did you use with the Palm Emulator? For that matter,
>which version of the Palm Emulator did you use - the version that ships
>with CW for Palm OS R6 is the Palm OS Emulator 2.1d29.

>The Mac is running MacOS 9.0.4...

In addition to applying the 3.5 update 1, you should download 3.0a7 from
http://www.veryComputer.com/

Ron

--
 "...we feel it's truly the best of the bunch."
Internet Week Reviews...Java Wars 2000
http://www.veryComputer.com/


 
 
 

Using Palm SDK 3.5 with CW for Palm OS R6 (on the Mac)

Post by Tilman Skobows » Thu, 26 Oct 2000 04:00:00



> We're trying to use the 3.5 SDK with our CW for Palm OS R6 tools (Mac
> version), but experiencing lots of crashes when trying to use the
> de*. Has anybody out there done this successfully?

Yes.

Quote:> Which version of the Palm OS ROM did you use with the Palm Emulator?

Palm OS 3.1, downloaded from a PalmIIIx (german),
Palm OS 3.5 as it came from the Provider Pavillion (can't send this)
I think PalmOS 3.5 should work, if you download it from your PalmOS
device.

Quote:> For that matter, which version of the Palm Emulator did you use
> the version that ships with CW for Palm OS R6 is the Palm OS Emulator 2.1d29.

POSE 2.1xxx is somewhat out of date. If you want to use new features
like color, you need to use POSE 3.0aX (The latest I use is 3.0a7). You
can download this from the PalmOS Developer web site.
It is still alpha, but it seems that developer/alpha/beta doesn't really
count, since it works fair enough.

Quote:> The Mac is running MacOS 9.0.4...

I use 8.6 and I won't change (never change a running system - even on a
Mac this might be usefull sometimes), so I can't tell you anything about
it.

Quote:> When first installed, CW for Palm OS R6 comes integrated with the Palm OS
> 3.1 SDK - and this configuration works fine. But we'd like to be able to
> upgrade to the 3.5 SDK and keep using the Metrowerks IDE, if at all
> possible.

I remember an Palm De* Plugin update a while ago, which solves some
problems. I strongly recommend to check all places for updates on a
regular base.

There are some problems with Palm debugging in general. But we work on a
rather large Palm application where the ability of debugging is
essential. Most of the problems can be worked around somehow.
You just have to discipline yourself not to start an app, as long as
POSE tries to restart the system. Another one is: if your app runs into
an ErrFatalDisplay conditions, POSE asked you what to do and you chose
"DEBUG", the IDE would sometimes "crash" into MacsBug. If I hit GO once
or maybe even a second time, the IDE shows the correct line in the
de*.
Another problem we have is the following: We use a small programm to
automatically mount server volumes during startup. POSE crashes
somewhere in the GUSI part of the application, if I do not remove the
server volumes from the desktop.

If you have more questions I might be able to help you, but then you
might as well describe some of your problems in greater detail.

HTH
Tilman