Win XP CD-RW in Thinkpad ultrabay not working

Win XP CD-RW in Thinkpad ultrabay not working

Post by Chuck Humphre » Wed, 16 Jul 2003 04:00:47



I have upgraded my Thinkpad a21-m to Windows XP.  I am now having
problems with the Portable Drive Bay 2000, which I attach with the IBM
PCMCIA card.  At start up the drive flashes the power light in red,
but it does not turn green, and then goes out entirely.  This happens
early in the start up process, and Win XP does not try to install the
relevant drivers until much later in the start up process.

The batteries in the bay are good and the bay is recognized with a
flashing green light in a Thinkpad 770X running Win2000.  

The appropriate driver is provided in Win XP.  

Device manager tells me that the device has been recognized and is
installed, but will not start.  It gives "error code 10."  Microsoft
says this is a driver problem, but it seems to me that is not likely
the case since the appropriate driver is there.  Any ideas as to what
is interfering with this device running.

For what it is worth, the Microsoft tech wrote to me about this issue
as follows:
From the setupapi.log, I noticed this device is installed successfully
with Windows XP built-in driver, and it is recognized as IBM Portable
Drive Bay 2000 (PCMCIA). For your reference, Id like to list them:
====================================================
[2003/07/09 07:18:31 596.3 Driver Install]

#-019 Searching for hardware ID(s):
pcmcia\pcmcia-ide_card-3220,pcmcia\pcmcia-ide_card-0000-0000,pcmcia\pcmcia-0000-0000

#-198 Command line processed: C:\WINDOWS\system32\services.exe

#I022 Found "PCMCIA\PCMCIA-IDE_CARD-3220" in
C:\WINDOWS\inf\pnpscsi.inf; Device: "IBM Portable Drive Bay 2000
(PCMCIA)"; Driver: "IBM Portable Drive Bay 2000 (PCMCIA)"; Provider:
"Microsoft"; Mfg: "IBM Corporation"; Section name: "cbidfbay_Inst".

#I023 Actual install section: [cbidfbay_Inst]. Rank: 0x00000000.
Effective driver date: 07/01/2001.

#-166 Device install function: DIF_SELECTBESTCOMPATDRV.

#I063 Selected driver installs from section [cbidfbay_Inst] in
"c:\windows\inf\pnpscsi.inf".

#I320 Class GUID of device remains:
{4D36E97B-E325-11CE-BFC1-08002BE10318}.

#I060 Set selected driver.

#I058 Selected best compatible driver.

#-166 Device install function: DIF_INSTALLDEVICEFILES.

#I124 Doing copy-only install of "PCMCIA\PCMCIA-IDE_CARD-3220\1".

#-166 Device install function: DIF_REGISTER_COINSTALLERS.

#I056 Coinstallers registered.

#-166 Device install function: DIF_INSTALLINTERFACES.

#-011 Installing section [cbidfbay_Inst.Interfaces] from
"c:\windows\inf\pnpscsi.inf".

#I054 Interfaces installed.

#-166 Device install function: DIF_INSTALLDEVICE.

#I123 Doing full install of "PCMCIA\PCMCIA-IDE_CARD-3220\1".

#I163 Device not started: Device has problem: 0x0a:
CM_PROB_FAILED_START.

#I121 Device install of "PCMCIA\PCMCIA-IDE_CARD-3220\1" finished
successfully.
========================================================
Therefore, we can conclude the related installation file, pnpscsi.PNF
and pnpscsi.inf, works properly. The built-in driver is also
installed. However, this device still cannot work properly. I believe
we need to install the update driver for this device in Windows XP. I
have searched in IBM web site and did not found its driver for Windows
XP.

Help!?

Chuck Humphrey
(310) 833-8597