Cannot open schemas in the Biztalk Editor

Cannot open schemas in the Biztalk Editor

Post by <ikalen.. » Sat, 18 Aug 2001 01:03:05



I created simple schema in the biztalk Editor. After, I
created xml instance of this schema, and validated it.
Everything seemed to be correct.  
After that, I saved the schema and instance.  

The problem is that after all these steps I cannot open
this schema in the Biztalk Editor because it generates
this error "The file [filename] could not be properly
opened. Reason: parameter incorrect ".

I could open up this file on the other computers that have
biztalk, but not on mine. I reinstalled BizTalk but the
same problem persists.

My system is Win2000 Professional.  

I appreciate the help with this problem.

 
 
 

Cannot open schemas in the Biztalk Editor

Post by <ikalen.. » Sat, 18 Aug 2001 01:03:03


I created simple schema in the biztalk Editor. After, I
created xml instance of this schema, and validated it.
Everything seemed to be correct.  
After that, I saved the schema and instance.  

The problem is that after all these steps I cannot open
this schema in the Biztalk Editor because it generates
this error "The file [filename] could not be properly
opened. Reason: parameter incorrect ".

I could open up this file on the other computers that have
biztalk, but not on mine. I reinstalled BizTalk but the
same problem persists.

My system is Win2000 Professional.  

I appreciate the help with this problem.


 
 
 

Cannot open schemas in the Biztalk Editor

Post by STom » Sat, 18 Aug 2001 23:36:44


Can you attach the schema in question to your email?

STom

> I created simple schema in the biztalk Editor. After, I
> created xml instance of this schema, and validated it.
> Everything seemed to be correct.
> After that, I saved the schema and instance.

> The problem is that after all these steps I cannot open
> this schema in the Biztalk Editor because it generates
> this error "The file [filename] could not be properly
> opened. Reason: parameter incorrect ".

> I could open up this file on the other computers that have
> biztalk, but not on mine. I reinstalled BizTalk but the
> same problem persists.

> My system is Win2000 Professional.

> I appreciate the help with this problem.


 
 
 

Cannot open schemas in the Biztalk Editor

Post by Everett Ya » Sun, 19 Aug 2001 01:00:45


Can you post the schema so I can try if I can open it?

Everett Yang

 
 
 

Cannot open schemas in the Biztalk Editor

Post by Bo Gua » Thu, 23 Aug 2001 06:27:11


The problem can be solved by applying the BizTalk SP1
which you can download from MS web site now.  

I believe it's caused by the XML Parsers you installed on
that box.  There are some known issues about using MS XML
Parser 4 Beta with BizTalk.  Anyway, SP1 will fix it.

>-----Original Message-----
>I created simple schema in the biztalk Editor. After, I
>created xml instance of this schema, and validated it.
>Everything seemed to be correct.  
>After that, I saved the schema and instance.  

>The problem is that after all these steps I cannot open
>this schema in the Biztalk Editor because it generates
>this error "The file [filename] could not be properly
>opened. Reason: parameter incorrect ".

>I could open up this file on the other computers that
have
>biztalk, but not on mine. I reinstalled BizTalk but the
>same problem persists.

>My system is Win2000 Professional.  

>I appreciate the help with this problem.

>.

 
 
 

1. Biztalk Editor / Schemas / Open-Closed parameter

Hi everyone,

I have been trying to find an explanation to the open/closed parameter
for fields in a schema (using Biztalk Editor for Biztalk 2002) and
have read a few posts about it (especialy one by Simon Khor :
http://groups.google.fr/groups?hl=fr&lr=&ie=UTF-8&threadm=7b466abb.01...
and the related msdn documentation). Yet it is quite unclear what it
allows to do.

I understand it allows for more flexibility in using fields in the
input document that aren't specified in the schema associated at
channel level. This means that any tag with an 'open' option set would
allow for undeclared subtags in the actual document.
Additionaly, it seems that you still have to include in the schema a
reference to the namespace the additional fields would refer to. Am I
wrong here ? Carrying on, this means you have to specify in the
document the namespace each tag is refering to, using the name or
letter you gave it in the 'namespace' tab in biztalk editor. So this
means that setting a tag to open in the schema allows for inclusion
(below) of other tags as long as they are declared in the additional
namespaces and you specify which it is relating to, doesn't it ?
It is getting fairly complex here, so to simplify my question :
- if what I have written above is right, where would you store the
second schema and how would you refer to it in the namespace setting ?
something like urn:webdav:theschema_name ? where would it actually dig
it from and does it 'download' it at runtime ?
- if not, basicaly what I want to do is be able to post document with
a few additional fields wherever they are located in the document, and
let them through the channel. I have run tests with the tags set to

doesn't work and the error I get is the document doesn't match the
DTD, yet I don't know where the error was thrown from : channel entry
or mapping.

Any help and/or ideas would be appreciated,
TIA

Justin

2. **NEEDED!*** Windows drivers for Tandy DMP 103A printer!

3. Cannot open a file from BizTalk Editor or Mapper

4. Analog to IP adapters

5. Edit schema for delimited file in BizTalk Editor

6. Not getting exploder messages

7. XML file could not be properly opened by BizTalk editor

8. Biztalk Editor Can't Open XML documents

9. Unable to open a file in BizTalk Editor or Mapper

10. Can't open cxml.dtd using BizTalk editor

11. Don't open xml file in BizTalk Editor

12. Schema editor