TP 560Z, Win 98, Com1 needed before Win 98 loads

TP 560Z, Win 98, Com1 needed before Win 98 loads

Post by Greg Lar » Mon, 14 Dec 1998 04:00:00




>    I need to load a TSR on a IBM ThinkPad 560Z before it loads Winodws 98,
>( So it is in the autoexec.bat). However it can't find the hardware on the
>com1 port because the BIOS was setup for PNP because Windows 98 was
install.
>(Quick Bootup). I try turning off QuickBoot but it has no effect ( Because
>Windows 98 supports PNP). Is their another way to tell it to assign the com
>ports before Windows 98 does? Once Windows 98 loads, I can load this TSR
and
>access the COM1 port, but I need to access it before. Any ideas?

(My advice is based on a knowledge of the 95 boot process, and I don't know
if 98 behaves the same way.)

Try setting the machine to not boot automatically into GUI mode. You can do
this either by using the Microsoft Powertoy "TweakUI," or by editing
msdos.sys (use attrib -h -s -r msdos.sys to make it visible), and changing
the line that sets it to boot into the GUI automatically. This is something
like BootGUI=1. Changing it to 0 will make it boot to the command line. Put
a line at the end of your autoexec.bat file that calls another batch file
that loads the tsr. Then, if you want to boot to GUI mode, just put in the
'win' command.

Let us know if it works...

Greg L.
Renaissance Computer Resources

 
 
 

TP 560Z, Win 98, Com1 needed before Win 98 loads

Post by Star Computer Service » Tue, 15 Dec 1998 04:00:00


    I need to load a TSR on a IBM ThinkPad 560Z before it loads Winodws 98,
( So it is in the autoexec.bat). However it can't find the hardware on the
com1 port because the BIOS was setup for PNP because Windows 98 was install.
(Quick Bootup). I try turning off QuickBoot but it has no effect ( Because
Windows 98 supports PNP). Is their another way to tell it to assign the com
ports before Windows 98 does? Once Windows 98 loads, I can load this TSR and
access the COM1 port, but I need to access it before. Any ideas?

Thanks
Sheldon