Initial comments - TOS 2.06

Initial comments - TOS 2.06

Post by Adam Tilghm » Mon, 02 Mar 1992 17:00:04



     I just finished installing TOS 2.06 in my 520STe, and after
playing with it for a few hours I have a few comments:
        It "seems" much faster - not that it's actually faster,
                but Atari seems to have hidden its slowness
                through (careful?) design... Pretty nice!
        MiNT works with it. (yeah!)
        STalker doesn't detect alt-keypad ## keypresses, probably
                because of the new "feature" to access all 256
                chars.  Did this really *need* to be in _ROM_?
                Is there a fix for it?
        The Desktop uses the Atari fileselector even though I've
                loaded up an alternate.  All other programs use
                the alternate, but the Desktop chugs along with
                same old thing.  Are we seeing Atari make direct
                calls to the Fileselect() routine instead of
                doing it like everyone else? Hmm....
        Turbo ST doesn't work.  No surprise here, I guess I'll just
                have to switch to Quick ST.  Oh well :-)

    Anybody else have any comments?

   -- adam

--

==  "Martha, fetch my rifle - thar's another UCSD ECE undergrad!"  ==

 
 
 

Initial comments - TOS 2.06

Post by Udo Erdelho » Wed, 04 Mar 1992 07:34:46



Quote:>     I just finished installing TOS 2.06 in my 520STe, and after
>playing with it for a few hours I have a few comments:

Using TOS 2.06 on a TEC since mid-december 1991, I've got to add some
more..

Quote:>    STalker doesn't detect alt-keypad ##
>            Did this really *need* to be in _ROM_? Is there a fix for it?

Does this have to be in Stalker, if it's already in ROM? Why waste user
memory for a functionality already build in?

Quote:>    The Desktop uses the Atari fileselector even though I've
>            loaded up an alternate.  All other programs use
>            the alternate, but the Desktop chugs along with
>            same old thing.  Are we seeing Atari make direct
>            calls to the Fileselect() routine instead of
>            doing it like everyone else? Hmm....

The Desktop always uses direct jumps into all functions...

Quote:>    Turbo ST doesn't work.  No surprise here, I guess I'll just
>            have to switch to Quick ST.  Oh well :-)

Forget about those (censored) Line-A-Speeders like Turbo ST, Quick ST. Get
NVDI from Bela instead. It offers as much speed as Quick ST or Turbo ST,
but is more compatible like these two (ever tried to run .TOS or .TTP
programs in Gemini's Mupfel window while QuickST/TurboST were active?) and
has a GDOS build in.

Quote:>    Anybody else have any comments?

I think you've forgotten an important thing for users of a modem (or the
serial port in general). At first, RTS/CTS works without ANY patch program.
No more messing around with HSFIX, TURBOCTS, TOS14FIX or whatsoever. It just
works, even at high speed. No problems here with my HST...

Secondary, TOS 2.06 is prepared to use alternate RAM. It's going to be much
easier to have more than 4 Megs on a normal ST.

Third, TOS 2.06 is much safer when regarding accs and resolution changes.
Did you ever try Atari's new modular control panel on a ST with TOS < 2.00?
It offers a point "Switch Off" (may sound a little bit different, I only have
the German version) because resolution changes with .ACC installed on these
old TOS-Versions may cause everything (The ACCs get no information about it,
they think they have their memory, but they do not have it). On TOS => 2.00,
there are no such problems.

/s/ Udo
--


 
 
 

Initial comments - TOS 2.06

Post by Roger.Shepp.. » Thu, 05 Mar 1992 21:41:13




> >     I just finished installing TOS 2.06 in my 520STe, and after
> >playing with it for a few hours I have a few comments:
> Using TOS 2.06 on a TEC since mid-december 1991, I've got to add some
> more..

> >    Anybody else have any comments?
> I think you've forgotten an important thing for users of a modem (or the
> serial port in general). At first, RTS/CTS works without ANY patch program.
> No more messing around with HSFIX, TURBOCTS, TOS14FIX or whatsoever. It just
> works, even at high speed. No problems here with my HST...

**********

I have bean reading some information on a BBS and the person stated it was not
posible to fix the CTS fault unless you did hardware changes, the MPF 68901
interrupt priority levels were to low to handle the CTS interrupt..

**********

> /s/ Udo
> --


--

***  85 Donovan Rd        *    *   GEnie.  R.SHEPPARD5               ***
***  Kapiti                        At least I don't Flicker,         ***
***  New Zealand..          *      not like a dying light globe      ***
 
 
 

Initial comments - TOS 2.06

Post by Ralph P. Sob » Sat, 07 Mar 1992 20:43:55


RS> I have bean reading some information on a BBS and the person
RS> stated it was not posible to fix the CTS fault unless you did
RS> hardware changes, the MPF 68901 interrupt priority levels were to
RS> low to handle the CTS interrupt..

Normally now, RTS/CTS works right in machines with TOS 1.02 (like mine
:-), right?  So, if *I* got an upgrade to TOS 2.06 I would suppose
that RTS/CTS should still work?

Comments anyone?

--
Ralph P. Sobek                    Disclaimer: The above ruminations are my own.



Phone: (+33-)61-33-62-66  FAX-1: (+33-)61-33-64-55  FAX-2: (+33-)61-55-35-77
===============================================================================
Got a Mega 4 ST. Wish it was a Mega STe? :-|  Do I *really* want a TT/Next? ;~#

 
 
 

Initial comments - TOS 2.06

Post by Craig Sho » Sun, 08 Mar 1992 00:33:26




> >     I just finished installing TOS 2.06 in my 520STe, and after
> >playing with it for a few hours I have a few comments:
> Using TOS 2.06 on a TEC since mid-december 1991, I've got to add some
> more..

Just where do these new versions come from? Are they sold in retail
otlets? or are they distributed free?

 Craig.

+----------+-----------------------------------------------+------------+
|  *****   |                Craig Shore                    |  ChCh,     |
|*  * *  * |                                               | New Zealand|

|  *****   |        SLNET - 250:700/1266  FIDO - 3:770/120 |   / /\     |
+----------+------------------------+----------------------+------------+
| Equinox Networks Ph +64 3 3854406 |   Trashcan BBS Ph +64 3 799345    |
+-----------------------------------+-----------------------------------+

 
 
 

1. Going Back to TOS 1.0 or 1.2 from TOS 2.06

Isn't there a program which reconfigures an ST (Mega 4) running TOS
2.06 to act like one running TOS 1.0 or 1.2?  I found a few old
programs that now give bombs on TOS 2.06.

I vaguely remember that such a program exists, but do not remember its
name, or where it can be found.

Thanks in advance,

--
Dr. Ralph P. Sobek                Disclaimer: The above ruminations are my own.



FAX:       (+33) 61-19-30-00
===============================================================================
Got a Sun IPC lap clone w/1.05 GB!  Got a Mega 4STfm with TOS 2.06, floptical!

2. Rumors of Death of Enterprise Are Greatly Exaggerated

3. TOS 2.06 chips to replace TOS 2.05 in MegaSTe

4. Create a Category Group?

5. FS: Gemulator TOS-boartd with TOS 2.06

6. Computer freezes up

7. TOS 2.06 upgrade board

8. WANTED: TOS 2.06 chips set.

9. **** which EPROM for TOS 2.06 in ST ??? ****

10. TOS 2.06 Upgrade Hack

11. Plea for help: TOS 2.06 image

12. TOS 2.06