So much for kerberos in SunOS 4.1 (inside the US)

So much for kerberos in SunOS 4.1 (inside the US)

Post by Dave Edmonds » Tue, 16 Oct 1990 18:01:37



wisner> I got Kerberos compiled on my Sun 4/60 (SPARCstation-1). Had to edit
wisner> make_commands.c to do it, but it compiled. But it won't run. Whenever
wisner> I try to start up the kerberos server, it fails to bind the socket --
wisner> "Address already in use". Any suggestions?
I had this at one point.  there were two possible problems:
        i) the CAP (macintosh related) software uses some of the same
        ports, if you still have the `old' setup (newer ones use ports
        down in the 200 region)
        ii) the portmapper can be grabbing some of the ports in that
        region
if the problem is (i), then you should probably move your cap
listeners to the newer port numbers.  then you'll get hit by (ii) :-)
i moved the kerberos ports as well, but i'm a bit worried that this
bodes badly for inter-realm authentication (which i'm not likely to
try for a long while yet).  is it just sun's portmapper that grabs
ports in this area (700+) ?

dave.
---
Dave Edmondson, Systems Support.                     Opinions are all my own.
Department of Computing, Imperial College of Science, Technology and Medicine,
180 Queen's Gate, London SW7 1BZ. phone: 071-589-5111 x5085 fax: 071-581-8024

  ``Be selective, be objective, be an asset to the collective'' -- Jazzy B

 
 
 

So much for kerberos in SunOS 4.1 (inside the US)

Post by Mark Ste » Wed, 17 Oct 1990 00:48:30


wisner> I try to start up the kerberos server, it fails to bind the socket --
wisner> "Address already in use". Any suggestions?

dme> ii) the portmapper can be grabbing some of the ports in that
dme> region

You can check this easily by running "rpcinfo -p" and checking the
port registrations that rpc services have made via portmap.  If the
kerberos port has been used in this manner, then start up kerberos
before portmap in rc.local.

--Mark

 
 
 

1. So much for kerberos in SunOS 4.1 (inside the US)

I got Kerberos compiled on my Sun 4/60 (SPARCstation-1). Had to edit
make_commands.c to do it, but it compiled. But it won't run. Whenever
I try to start up the kerberos server, it fails to bind the socket --
"Address already in use". Any suggestions?

w.

2. exploroer.exe 100% CPU Usage

3. Building Kerberos for SunOS 4.1.x - Help!

4. #return

5. Help: Build MIT Kerberos V5 on sunos 4.1.x machine

6. SNMP and NT 4 Server

7. Distiller for SunOS 4.1.x

8. Modem Help Line.....

9. HP DAT drives on SunOS 4.1.x

10. SunOS 4.1 & vi

11. SNMP daemon for SunOS 4.1

12. Some Comments on Building Ptolemy0.5 on Sparc SunOS 4.1.X (gcc)

13. \TimeZoneComp in Medley 1.15 on Sparcstation 1 running SunOS 4.1