Kerberos V4 for Solaris 2.3?

Kerberos V4 for Solaris 2.3?

Post by Andrew Donk » Fri, 06 Jan 1995 05:13:54



|has anyone successfully compiled Kerberos V4 under Solaris 2.3?

Yes - most of it.  I haven't ported the applications in the "bsd," "tftp,"
or "knetd" directories because I only need the server and libraries.

|As it stands, the code does not seem to have any support for Solaris
|(although the FAQ's imply that it is supported),

Judging by the amount of work required to build it, they shouldn't.

|we require V4 specifically to work with the Mandarin software.

Ditto.  V5 builds like a charm (sans crypto libraries, of course), but
we're planning on using Mandarin also.

There are two things we can do.  Either get

ftp://ftp.cs.waikato.ac.nz/pub/packages/kerberos/krb4-ard-farted.tar.gz

...which is an archive of my whole kerberos source tree I made a while back
for someone else here at the university struggling to build krb4 on any
platform.

The problem with that is that I have changed various pathnames and other
bits and pieces, and you won't know what differs from the stock
distribution ("eBones.tar.Z").  For example, I've changed all the macros
using "/kerberos/..." to "/opt/kerberos/..."  Also, if you're like me, you
won't want to build system software that someone else has fiddled with.
Here's plan B:

Get "eBones.tar.Z" from one of the main sites and apply some of the changes
described in my notes file (which I'll mail you if you request it).  You
can decide for yourself which changes are local customisations and which
are purely porting issues, and you'll get a good idea of how the code works
in the process.

Good luck

|-----

|Systems Engineer
|Deakin University, Australia

,------------------------------------------------------------------------,

|          Department of Computer Science, University of Waikato         |
`------------------------------------------------------------------------'

 
 
 

Kerberos V4 for Solaris 2.3?

Post by Robert Sturro » Thu, 05 Jan 1995 19:31:26


Hi,

has anyone successfully compiled Kerberos V4 under Solaris 2.3?

As it stands, the code does not seem to have any support for Solaris
(although the FAQ's imply that it is supported), and I'm struggling
badly trying to get it to compile.  I realise that V5 is available, but
we require V4 specifically to work with the Mandarin software.

Any help appreciated.

-----

Systems Engineer
Deakin University, Australia

 
 
 

1. kerberos V4 or 5 on Solaris 2.3

Has anyone been able to compile kerberos V4 or V5 on a
Solaris 2.3 box. If so please send me e-mail on a place
the source can be found or a place where a precompiled
version for Solaris can be found.  It would be greatly
appreciated.  Please send mail directly as I check this
newsgroup very rarely...  Thank you in advance...
-Damon-

2. Need help clearing static routing tables

3. Kerberos on Solaris 2.3(4)

4. Wire up an Event

5. kerberos 4 for solaris 2.3

6. Looking for Unix-based Data Modeling tool

7. Kerberos IV for Solaris 2.3

8. copyright symbol

9. Kerberos v5 for Solaris 2.3

10. Kerberos 4 for Solaris 2.3

11. Kerberos on Solaris 2.3

12. Kerberos port to Solaris 2.3 ?