MRTG Newbie needs help with MRTG on Solaris 8 SPARC Edition

MRTG Newbie needs help with MRTG on Solaris 8 SPARC Edition

Post by Noah » Sat, 15 Sep 2001 01:16:48



I have loaded the following packages from sunfreeware.com:

gcc-2.95.3-sol8-sparc-local    
gd-1.8.3-sol8-sparc-local      
libpng-1.0.11-sol8-sparc-local  
zlib-1.1.3-sol8-sparc-local

and

mrtg-2.9.14

The package installs and the compilation/install of MRTG went fine.  I
successfully used cfgmaker to create a MRTG configuratin file.

When I attempt to execute mrtg, I get the following errors:

ustemime56:/export/home/mrtg> mrtg /export/home/mrtg/cfg/mrtg.cfg

gd-png:  fatal libpng error: Application must be recompiled; version
1.0.6 was incompatible
2001-09-13 09:10:54 -- WARNING: rateup died from Signal 11
 with Exit Value 0 when doing router '64.0.14.50_1'
 Signal was 11, Returncode was 0
gd-png:  fatal libpng error: Application must be recompiled; version
1.0.6 was incompatible
2001-09-13 09:10:54 -- WARNING: rateup died from Signal 11
 with Exit Value 0 when doing router '64.0.14.50_3'
 Signal was 11, Returncode was 0
gd-png:  fatal libpng error: Application must be recompiled; version
1.0.6 was incompatible
2001-09-13 09:10:54 -- WARNING: rateup died from Signal 11
 with Exit Value 0 when doing router '64.0.14.50_6'
 Signal was 11, Returncode was 0
gd-png:  fatal libpng error: Application must be recompiled; version
1.0.6 was incompatible
2001-09-13 09:10:55 -- WARNING: rateup died from Signal 11
 with Exit Value 0 when doing router '64.0.14.50_9'
 Signal was 11, Returncode was 0
ustemime56:/export/home/mrtg>

I am do not undertstand the reference to "version 1.0.6".  None of the
software that I have installed is version "1.0.6".

I tried to look through the install documentation and the FAQ, but I
cannot find an answer.  If there is an manual to RTFM, then please
advise as to the location.

Thanks in advance,

Noahal

 
 
 

MRTG Newbie needs help with MRTG on Solaris 8 SPARC Edition

Post by Glenn Randers-Pehrs » Sat, 15 Sep 2001 09:40:12



> When I attempt to execute mrtg, I get the following errors:
> gd-png:  fatal libpng error: Application must be recompiled; version
> 1.0.6 was incompatible

> I am do not undertstand the reference to "version 1.0.6".  None of the
> software that I have installed is version "1.0.6".

It means that sometime in the past you built "gd" using libpng version 1.0.6.
Since then you replaced libpng with a newer version (1.0.11) which is
incompatible with version 1.0.6.  You must rebuild "gd" with your current
version of libpng.

Glenn

 
 
 

1. newbie MRTG question : how to add mib to MRTG ?

Hi,

I'm a MRTG newbie and am trying to get it work with Xylan Omniswitch,
the problem is, I can't find the MIB files from popular MIB libraries...

At last, I got the xylan mib, but the simple question is, how do I add
the mib into MRTG ? I'm using MRTG on WinNT & Win98

Any help appreciated !!

alex

Sent via Deja.com
http://www.deja.com/

2. 386sx25 & AMEMS152.lha

3. MRTG newbie help help

4. Max speed of IBM Int????

5. MRTG and SUN Solaris - what do I need to get working ?

6. Palmtop w Mac?

7. Newbie @ MRTG Help!!!!!!!!!

8. surplus O2 regulators

9. Newbie help - MRTG->Disk space.

10. MRTG: STAT.PL Erros help please < newbie>

11. Newbie Help, MRTG and 3 Com Hiper Arc

12. Need help with ppp on Sun Sparc/Solaris

13. How to debug MRTG - (My MRTG instance stop without reason)